summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-13 17:27:32 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-13 18:07:36 +0000
commit6f766ed1ce65cd3ece33a12cd76afbfdf412a1b6 (patch)
treeaf13d2b0610da6ea5054d62097550ecb43917744
parent306828d91540e9ce11cafc701d7021845610d14b (diff)
dgit: Set default dsc import distro when suppressing Dgit field.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7668c10..1ff7529 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,7 @@ dgit (3.3~) unstable; urgency=medium
Bugfixes:
* dgit: Remove a leftover debugging print.
* dgit: Set default dsc import distro when there is no Dgit field.
+ * dgit: Set default dsc import distro when suppressing Dgit field.
Packaging:
* Remove redundant Recommends on libtext-iconv-perl.
diff --git a/dgit b/dgit
index a0802eb..f4a470d 100755
--- a/dgit
+++ b/dgit
@@ -6117,6 +6117,7 @@ sub cmd_import_dsc {
parse_dsc_field($dsc, "Dgit metadata in .dsc")
unless forceing [qw(import-dsc-with-dgit-field)];
+ parse_dsc_field_def_dsc_distro();
if (defined $dsc_hash) {
progress "dgit: import-dsc of .dsc with Dgit field, using git hash";