summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:35:23 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-18 21:35:24 +0000
commit8df7ac2d5674abb5cb0cddec8476fc045ad2f074 (patch)
tree22366bfbbb4030cb51ab84c5c052bd113cb77185
parente0d892c7037eb8f89f6dc3ce166e7f24484df7c6 (diff)
test suite: downstream-gitless: Test import of .dsc with unsafe url.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/tests/downstream-gitless3
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 5b9ef0e..0fd00bb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -10,6 +10,7 @@ dgit (3.6~) unstable; urgency=medium
Test suite:
* downstream-gitless: Test import of .dsc from unknown distro.
+ * downstream-gitless: Test import of .dsc with unsafe url.
--
diff --git a/tests/tests/downstream-gitless b/tests/tests/downstream-gitless
index c70c50f..6b2df1b 100755
--- a/tests/tests/downstream-gitless
+++ b/tests/tests/downstream-gitless
@@ -77,6 +77,9 @@ t-dgit clone example avon example.avon
perl -i -pe 's/ test-dummy / unknown-distro / if m/^Dgit:/' $dscf
cd $p.import
+t-expect-fail 'hinted url with protocol file which is unsafe' \
+t-dgit import-dsc $dscf xunk
+
t-git-config dgit.dsc-url-proto-ok.file true
t-dgit import-dsc $dscf xunk