summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-12-21 19:23:00 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-12-21 19:23:00 +0000
commit230384a7474c7efa00d4fb1bcd4182ea6d4d12fa (patch)
tree78199e82b7cad7812182fbf240c55f450b86a01e
parentac98a9a99e592b92f719745a0b08142b5ddc21f9 (diff)
Use newest (not oldest) version currently in suite when calculating what value to use for -v<version> by default. Closes:#732781.debian/0.20
-rw-r--r--debian/changelog7
-rwxr-xr-xdgit2
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 73763bc..1c2ca2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+dgit (0.20) unstable; urgency=high
+
+ * Use newest (not oldest) version currently in suite when calculating
+ what value to use for -v<version> by default. Closes:#732781.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 21 Dec 2013 19:13:56 +0000
+
dgit (0.19) unstable; urgency=low
Testing facilities:
diff --git a/dgit b/dgit
index 9b895b0..61af3b8 100755
--- a/dgit
+++ b/dgit
@@ -1803,7 +1803,7 @@ sub changesopts () {
my @vsns = archive_query('archive_query');
if (@vsns) {
@vsns = map { $_->[0] } @vsns;
- @vsns = sort { version_compare_string($a, $b) } @vsns;
+ @vsns = sort { -version_compare_string($a, $b) } @vsns;
$changes_since_version = $vsns[0];
progress "changelog will contain changes since $vsns[0]";
} else {