summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 12:56:48 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 12:56:48 +0100
commit82e96b6ad7d79f252e5343407cf2f718d3e03918 (patch)
tree637693790bc3ee201c43322afe8450d2d976bdbd
parentf2a1ab46505797714043bb64897135972f9ffe09 (diff)
finalise 0.17~experimental2debian/0.17_experimental2
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit17
2 files changed, 8 insertions, 11 deletions
diff --git a/debian/changelog b/debian/changelog
index 89f416e..ae985a5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,7 +6,7 @@ dgit (0.17~experimental2) experimental; urgency=low
Changes to remote functionality:
* More bugfixes.
- --
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Wed, 23 Oct 2013 12:56:34 +0100
dgit (0.17~experimental1) experimental; urgency=low
diff --git a/dgit b/dgit
index 497687a..5308386 100755
--- a/dgit
+++ b/dgit
@@ -1504,16 +1504,6 @@ sub cmd_rpush {
};
i_method "i_resp", $icmd, $iargs;
}
-
- my $pid = $i_child_pid;
- $i_child_pid = undef; # prevents killing some other process with same pid
- printdebug "waiting for remote child $pid...";
- my $got = waitpid $pid, 0;
- die $! unless $got == $pid;
- die "remote child failed $?" if $?;
-
- i_cleanup();
- exit 0;
}
sub i_resp_progress ($) {
@@ -1523,6 +1513,13 @@ sub i_resp_progress ($) {
}
sub i_resp_complete {
+ my $pid = $i_child_pid;
+ $i_child_pid = undef; # prevents killing some other process with same pid
+ printdebug "waiting for remote child $pid...";
+ my $got = waitpid $pid, 0;
+ die $! unless $got == $pid;
+ die "remote child failed $?" if $?;
+
i_cleanup();
exit 0;
}