summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-01-22 17:09:50 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 12:25:49 +0100
commit942637ea633f1c9dc0be2534a660296a76b87e27 (patch)
tree0473be9f4568aea6974c5daa3e87a73e8aadda7d
parent012a80b3779e6241c270b73771f1d5019c1ca196 (diff)
Dgit.pm, dgit: Break $extra_orig_namepart_re out into Dgit.pm.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Debian/Dgit.pm2
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
3 files changed, 4 insertions, 2 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index d086cbe..a4ec377 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -53,6 +53,7 @@ BEGIN {
git_for_each_tag_referring is_fast_fwd
$package_re $component_re $deliberately_re
$distro_re $versiontag_re $series_filename_re
+ $extra_orig_namepart_re
$branchprefix
initdebug enabledebug enabledebuglevel
printdebug debugcmd
@@ -80,6 +81,7 @@ our $distro_re = $component_re;
our $versiontag_re = qr{[-+.\%_0-9a-zA-Z/]+};
our $branchprefix = 'dgit';
our $series_filename_re = qr{(?:^|\.)series(?!\n)$}s;
+our $extra_orig_namepart_re = qr{[-0-9a-z]+};
# policy hook exit status bits
# see dgit-repos-server head comment for documentation
diff --git a/debian/changelog b/debian/changelog
index 8d830f0..e413454 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,7 +5,7 @@ dgit (4.5~) unstable; urgency=medium
Internal changes:
* Move $playground global to dgit.
- * Break git_get_symref out into Dgit.pm.
+ * Break git_get_symref and $extra_orig_namepart_re out into Dgit.pm.
--
diff --git a/dgit b/dgit
index aaafefb..573f39a 100755
--- a/dgit
+++ b/dgit
@@ -95,7 +95,7 @@ our %format_ok = map { $_=>1 } ("1.0","3.0 (native)","3.0 (quilt)");
our $suite_re = '[-+.0-9a-z]+';
our $cleanmode_re = 'dpkg-source(?:-d)?|git|git-ff|check|none';
-our $orig_f_comp_re = 'orig(?:-[-0-9a-z]+)?';
+our $orig_f_comp_re = qr{orig(?:-$extra_orig_namepart_re)?};
our $orig_f_sig_re = '\\.(?:asc|gpg|pgp)';
our $orig_f_tail_re = "$orig_f_comp_re\\.tar(?:\\.\\w+)?(?:$orig_f_sig_re)?";