summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-08 22:31:09 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-08 22:37:27 +0100
commitda9855227636c46d09546eacedd95aa8ace7185a (patch)
tree30afb977d9ff6997960964b2d510c4b6dd62c325
parent97f49a475f82fa7526767cec5dad23669f3b394d (diff)
Actually understand foo,-security (!)
There does not in fact seem to have been any code which implements this line from dgit(7): If a specified subsuite starts with - then mainsuite is prepended. The code which canonicalises it back to the version with ",-" does work, though. Closes:#867189. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 3aa6a14..7c8db9f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,7 @@ dgit (3.11~) unstable; urgency=high
Prompted by #867603.
* Clone multisuite works even without --no-rm-on-error. Closes:#867434.
* Work if "git init" does not create $GIT/info. Closes:#858054.
+ * Actually understand foo,-security (!) Closes:#867189.
Important bugfixes to other components:
* dgit-badcommit-fixup: Honour core.sharedRepository. Closes:#867603.
diff --git a/dgit b/dgit
index 743e869..ccf5009 100755
--- a/dgit
+++ b/dgit
@@ -3499,6 +3499,7 @@ sub fork_for_multisuite ($) {
$before_fetch_merge->();
foreach my $tsuite (@suites[1..$#suites]) {
+ $tsuite =~ s/^-/$cbasesuite-/;
my $csubsuite = multisuite_suite_child($tsuite, \@mergeinputs,
sub {
@end = ();