summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-14 14:34:27 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-14 18:35:04 +0100
commite02ad8575f1d5f247a77c8a5d009a7477514be2f (patch)
tree78ddcc01008e0dce06a84b31ffa4870d66b6c584
parent8f52891ef4c7a803a1d8576897180a34b36a4e16 (diff)
Finish dealing with uncuddled options
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit3
-rw-r--r--dgit.12
3 files changed, 2 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 59bcf79..0a4078c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,7 +7,8 @@ dgit (1.2~~) UNRELEASED; urgency=low
* Correct manpage cross-reference to point to browse.d.d.o.
* Honour *.clean-mode configuration setting for --clean= mode.
* In manpage move dgit.default.* to main CONFIGURATION section.
- * WIP improvements to option handling of options with values
+ * No longer require option values to be cuddled: support `--opt val' and
+ `-o val'. Closes:#763332.
--
diff --git a/dgit b/dgit
index 6ca1f33..eb9a97c 100755
--- a/dgit
+++ b/dgit
@@ -3246,9 +3246,6 @@ sub parseopts () {
push @ropts, $&;
push @changesopts, $_;
$_ = '';
- } elsif (m/^-[dCk]$/) {
- badusage
- "option \`$_' requires an argument (and no space before the argument)";
} elsif (s/^-wn$//s) {
push @ropts, $&;
$cleanmode = 'none';
diff --git a/dgit.1 b/dgit.1
index b56a8fd..926a9c6 100644
--- a/dgit.1
+++ b/dgit.1
@@ -785,8 +785,6 @@ There should be an option which arranges for the `3.0 (quilt)'
autocommit(s) to not appear on your HEAD, but instead only in the
remote tracking suite branch.
-The option parser requires values to be cuddled to the option name.
-
--dry-run does not always work properly, as not doing some of the git
fetches may result in subsequent actions being different. Doing a
non-dry-run dgit fetch first will help.