summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-31 13:28:41 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-31 13:28:42 +0100
commite5d430e4208757b874443779b75ca884a143aa6a (patch)
tree65ab7d6ec6eef305f7120c6efa56d3f1233010be
parentc83cc428208bee99de3b75158b9779449403ee1b (diff)
git-debrebase: Improve error messages for bad options.
* GetOptions calls warn(). So we need a wrapper which disables or $SIG{__WARN__} (which prints a stack trace). * Put the call to badusage in the wrapper. * Change the messages to be clearer about what is meant. * Add the program name to the badusage message. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xgit-debrebase21
2 files changed, 16 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 4d6e50a..dc87466 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ dgit (6.3~) unstable; urgency=medium
* git-debrebase: new-upstream: Fix handling of epochs.
* git-debrebase: convert-from-gbp: Use same algorithm for finding
upstream commitish as new-upstream. Closes:#905062.
+ * git-debrebase: Improve error messages for bad options.
--
diff --git a/git-debrebase b/git-debrebase
index 2687ef1..439a10a 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -45,10 +45,16 @@ $|=1;
sub badusage ($) {
my ($m) = @_;
- print STDERR "bad usage: $m\n";
+ print STDERR "$us: bad usage: $m\n";
finish 8;
}
+sub getoptions {
+ my $m = shift;
+ local $SIG{__WARN__}; # GetOptions calls `warn' to print messages
+ GetOptions @_ or badusage $m;
+}
+
sub cfg ($;$) {
my ($k, $optional) = @_;
local $/ = "\0";
@@ -1518,7 +1524,8 @@ sub cmd_status () {
sub cmd_stitch () {
my $prose = 'stitch';
- GetOptions('prose=s', \$prose) or badusage("bad options to stitch");
+ getoptions("bad options follow \`git-debrebase stitch'",
+ 'prose=s', \$prose);
badusage "no arguments allowed" if @ARGV;
do_stitch $prose, 0;
}
@@ -1581,8 +1588,8 @@ sub make_patches ($) {
sub cmd_make_patches () {
my $opt_quiet_would_amend;
- GetOptions('quiet-would-amend!', \$opt_quiet_would_amend)
- or badusage("bad options to make-patches");
+ getoptions("bad options follow \`git-debrebase make-patches'",
+ 'quiet-would-amend!', \$opt_quiet_would_amend);
badusage "no arguments allowed" if @ARGV;
my $old_head = get_head();
my $new = make_patches $old_head;
@@ -1798,7 +1805,8 @@ sub cmd_downstream_rebase_launder_v0 () {
}
}
-GetOptions("D+" => \$debuglevel,
+getoptions("bad options\n",
+ "D+" => \$debuglevel,
'noop-ok', => \$opt_noop_ok,
'f=s' => \@snag_force_opts,
'anchor=s' => \@opt_anchors,
@@ -1814,7 +1822,8 @@ GetOptions("D+" => \$debuglevel,
# approach. '-i=s{0,}' does not work with bundling.
push @$opt_defaultcmd_interactive, @ARGV;
@ARGV=();
- }) or badusage "bad options\n";
+ });
+
initdebug('git-debrebase ');
enabledebug if $debuglevel;