summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-01 21:04:18 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-04 19:24:46 +0100
commite98a72a30420115e2e51b2317287f83a38daddba (patch)
tree09eb5c97c698bfcb4b0cfecadf6495ea2e8f4d47
parent71d71cb4e886f068fe5c6f29f265a4ff47df13d1 (diff)
Manpages: Improve formatting of alternative options, etc.
-rw-r--r--dgit.118
1 files changed, 9 insertions, 9 deletions
diff --git a/dgit.1 b/dgit.1
index e4da7f2..092c6e9 100644
--- a/dgit.1
+++ b/dgit.1
@@ -223,13 +223,13 @@ Tries to fetch a copy of the source code for the dgit-repos-server,
as actually being used on the dgit git server, as a git tree.
.SH OPTIONS
.TP
-.BR --dry-run | -n
+.BR --dry-run " | " -n
Go through the motions, fetching all information needed, but do not
actually update the output(s). For push, dgit does
the required checks and leaves the new .dsc in a temporary file,
but does not sign, tag, push or upload.
.TP
-.BR --damp-run | -L
+.BR --damp-run " | " -L
Go through many more of the motions: do everything that doesn't
involve either signing things, or making changes on the public
servers.
@@ -249,7 +249,7 @@ Specifies that we should process source package
rather than looking in debian/control or debian/changelog.
Valid with dgit fetch and dgit pull, only.
.TP
-.BR --clean=git | -wg
+.BR --clean=git " | " -wg
The source tree should be cleaned, before building a source package
with one of the build options, using
.BR "git clean -xdf" .
@@ -263,17 +263,17 @@ from being run.
the downside is simply that git clean may delete files you forgot to
git add.
.TP
-.BR --clean=none | -wn
+.BR --clean=none " | " -wn
Do not clean the tree before building a source package. If there are
files which are not in git, or if the build creates such files, a
subsequent dgit push will fail.
.TP
-.BR --clean=dpkg-source | -wd
+.BR --clean=dpkg-source " | " -wd
Use dpkg-buildpackage to do the clean, so that the source package
is cleaned by dpkg-source running the package's clean target.
This is the default. It requires the package's build dependencies.
.TP
-.BR -N | --new
+.BR -N " | " --new
The package may be new in this suite. Without this, dgit will
refuse to push.
.TP
@@ -335,7 +335,7 @@ because the dgit git tree does not have a
.B .pc
directory.)
.TP
-.BR --quilt=nocheck | --no-quilt-fixup
+.BR --quilt=nocheck " | " --no-quilt-fixup
Do not check whether up source format `3.0 (quilt)' metadata needs
fixing up. If you use this option and the metadata did in fact need
fixing up, dgit push will fail.
@@ -370,7 +370,7 @@ Passed to dpkg-genchanges (eventually).
Specifies a single additional option to pass, eventually, to
dpkg-genchanges.
.TP
-.RI \fB--curl=\fR program |\fB--dput=\fR program |...
+.RI \fB--curl=\fR program " | \fB--dput=\fR" program " |..."
Specifies alternative programs to use instead of
.BR curl ,
.BR dput ,
@@ -408,7 +408,7 @@ git to access dgit-repos, only git's idea of what ssh to use (eg,
.BR GIT_SSH )
is relevant.
.TP
-.RI \fB--curl:\fR option |\fB--dput:\fR option |...
+.RI \fB--curl:\fR option " | \fB--dput:\fR" option " |..."
Specifies a single additional option to pass to
.BR curl ,
.BR dput ,