summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-13 17:59:11 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-13 18:32:32 +0000
commitb2b20d54fb981df3e2ce295bb0b939a963afe1c2 (patch)
treee8af6bfbcb987dc6ecc078ae9b4c4300cd154dd2
parent6516b26b1e24241f879b9bde6533d1c8a384c803 (diff)
test suite: protocol-compat: check that we use the right distro
* Set distro to '' when running the import. This makes dgit fall back to the default distro. * Set the default distro to `foreign' (which has no settings, so we use builtin defaults). This only has any effect if the shell variable `distro' is set to the empty string - so it only takes effect during the import. * Set dgit-distro.foreign.cmd-git to false. This therefore detects if we ever try to do the import with the default distro's `git' command: we are supposed to be using the one from the .dsc. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xtests/tests/protocol-compat4
2 files changed, 6 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 04328fe..dfd59b7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,6 +14,8 @@ dgit (3.3~) unstable; urgency=medium
* Move default dsc distro config setting to lib. We need this
for the .dscs we have in tests/pkg-srcs/.
* test suite: defdistro-import-dsc: Drop this test.
+ * test suite: protocol-compat: check that we use the right distro
+ information when importing.
* test suite: Internal change: fix handling of nonempty distro=
--
diff --git a/tests/tests/protocol-compat b/tests/tests/protocol-compat
index 59e8d65..fcbeedb 100755
--- a/tests/tests/protocol-compat
+++ b/tests/tests/protocol-compat
@@ -6,6 +6,9 @@ set -e
t-setup-import examplegit
t-tstunt-parsechangelog
+t-git-config dgit.default.distro foreign
+t-git-config dgit-distro.foreign.cmd-git false
+
prep () {
dscf=$tmp/mirror/pool/main/example_$v.dsc
}
@@ -23,6 +26,7 @@ check () {
$1
+ local distro=''
t-dgit import-dsc $dscf +imported
t-ref-same refs/heads/imported
cd ..