summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-02-15 15:35:28 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 12:25:49 +0100
commit32264794f3d4b03366998e469cdb42ddeb979a5a (patch)
tree0f9ff08a7be79a0a5c36ea5db267ffe14ca9e6d8
parentac7dbb8eca4e6996bb06f175a4df6e7c0c2a19f8 (diff)
debian/control, git-debrebase: "use fnmatch;"
We are going to want this for globbing in the ffq configuration. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/control2
-rwxr-xr-xgit-debrebase1
-rwxr-xr-xtests/setup/gbp2gdr2
3 files changed, 3 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 4405e14..3180c85 100644
--- a/debian/control
+++ b/debian/control
@@ -15,7 +15,7 @@ Depends: perl, libwww-perl, libdpkg-perl, git-core, devscripts, dpkg-dev,
libdigest-sha-perl, dput, curl, apt,
libjson-perl, ca-certificates,
libtext-iconv-perl, libtext-glob-perl
-Recommends: ssh-client
+Recommends: ssh-client, libfile-fnmatch-perl
Suggests: sbuild
Architecture: all
Description: git interoperability with the Debian archive
diff --git a/git-debrebase b/git-debrebase
index 6655b2d..421a1cb 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -87,6 +87,7 @@ use POSIX;
use Data::Dumper;
use Getopt::Long qw(:config posix_default gnu_compat bundling);
use Dpkg::Version;
+use File::FnMatch qw(:fnmatch);
our ($opt_force, $opt_noop_ok);
diff --git a/tests/setup/gbp2gdr b/tests/setup/gbp2gdr
index da238f4..3f6d9a6 100755
--- a/tests/setup/gbp2gdr
+++ b/tests/setup/gbp2gdr
@@ -3,7 +3,7 @@ set -e
. tests/lib
. $troot/lib-gdr
-t-dependencies git-buildpackage
+t-dependencies git-buildpackage libfile-fnmatch-perl
t-tstunt-parsechangelog