summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-04 10:42:42 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-04 10:43:29 +0100
commit5026d3c30a7046299179ca3ba422fb21505cdf4d (patch)
tree54fff371066f68735685a30e283b2cb545480c19
parent32302c566f46426687ae9dcccec2f16ddeb56e4b (diff)
git-debrebase: Improve error message formatting from $bomb in walk
The : and ; were messed up. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xgit-debrebase4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 664a3d1..742b752 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ dgit (6.5~) unstable; urgency=medium
* dgit: Provide print-unapplied-treeish subcommand.
* dgit: Improve error message for unknown suite, to suggest -d.
* git-debrebase: Properly reject bare dgit dsc imports
+ * git-debrebase: Improve some error message formatting.
--
diff --git a/git-debrebase b/git-debrebase
index a2a14ca..eb0acb2 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -710,8 +710,8 @@ sub walk ($;$$) {
if ($nogenerate) {
return (undef,undef);
}
- fail "found unprocessable commit, cannot cope:".
- (defined $cl->{Why} ? "; $cl->{Why}": '').
+ fail "found unprocessable commit, cannot cope".
+ (defined $cl->{Why} ? "; $cl->{Why}:": ':').
" (commit $cur) (d.".
(join ' ', map { sprintf "%#x", $_->{Differs} }
@{ $cl->{Parents} }).