summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-08 17:47:33 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-08 19:26:31 +0100
commit573bb223c92c66b367114a0d1238be35013cdba2 (patch)
tree6dbe48d4e5150570d78434b1ef37a88d3a5c2265
parent9d91e25a38b64bce53bc315b2f69f1f99e4c1ef3 (diff)
Import: orig files: cope with signatures
Fix up .orig detection to handle .asc's (and other signatures) of .orig components the same way as their tarballs. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit4
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a55ee20..3cd6e8e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -58,6 +58,8 @@ dgit (1.5~~) unstable; urgency=medium
* Fix up .orig detection to be less trustful of (ambiguous) filenames.
* Fix up .orig detection to correctly allow exactly the right
.orig-comp components accorging to dpkg-source(1).
+ * Fix up .orig detection to handle .asc's (and other signatures)
+ of .orig components the same way as their tarballs.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index e11d2fb..e05c574 100755
--- a/dgit
+++ b/dgit
@@ -78,7 +78,8 @@ our %format_ok = map { $_=>1 } ("1.0","3.0 (native)","3.0 (quilt)");
our $suite_re = '[-+.0-9a-z]+';
our $cleanmode_re = 'dpkg-source(?:-d)?|git|git-ff|check|none';
our $orig_f_comp_re = 'orig(?:-[-0-9a-z]+)?';
-our $orig_f_tail_re = "$orig_f_comp_re\\.tar(?:\\.\\w+)?";
+our $orig_f_sig_re = '\\.(?:asc|gpg|pgp)';
+our $orig_f_tail_re = "$orig_f_comp_re\\.tar(?:\\.\\w+)?(?:$orig_f_sig_re)?";
our $git_authline_re = '^([^<>]+) \<(\S+)\> (\d+ [-+]\d+)$';
our $splitbraincache = 'dgit-intern/quilt-cache';
@@ -1593,6 +1594,7 @@ sub generate_commits_from_dsc () {
printdebug "import considering $f ";
(printdebug "only one dfi\n"), next if @dfi == 1;
(printdebug "not tar\n"), next unless $f =~ m/\.tar(\.\w+)?$/;
+ (printdebug "signature\n"), next if $f =~ m/$orig_f_sig_re$/o;
my $compr_ext = $1;
my ($orig_f_part) =