summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-10 13:28:21 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-10 14:06:39 +0000
commit584d67c264bfc9d759a5fc40f04cde62d3b0ec76 (patch)
tree4453b03cdb1075930fa4668c1bb7c6f9884313fc
parent41206be38908e773a8dab752e857f2935924571e (diff)
dgit: import-dsc: Add missing call to notpushing().
Avoids crashing with undefined $isuite. Closes:#850781. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8fa1f15..b0c8811 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (3.1~) unstable; urgency=medium
Bugfixes:
+ * dgit import-dsc: Do not crash with undefined $isuite. Closes:#850781.
* dgit: Do not nedlessly re-fetch the rewrite map.
--
diff --git a/dgit b/dgit
index d3673c2..eee1806 100755
--- a/dgit
+++ b/dgit
@@ -6105,6 +6105,8 @@ Specify +$specbranch to overwrite, discarding existing history
END
if $oldhash && !$force;
+ notpushing();
+
my @dfi = dsc_files_info();
foreach my $fi (@dfi) {
my $f = $fi->{Filename};