summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-11 16:56:36 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-08-11 17:05:56 +0100
commit8c4cbc9eafaff67f8029512a0b5e710fb5278390 (patch)
tree15e5936c2941e47f60779817ff4c5956d68594dd
parent9fe91f98a08e948bf3e282cd17f7c2637669a216 (diff)
git-debrebase: Do not bail making patches if there aren't any.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xgit-debrebase2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 325d37f..2b75575 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (6.7~) unstable; urgency=medium
* git-debrebase: Improve ffq head recording message.
* git-debrebase: Better (less copious by default) debug output.
+ * git-debrebase: Do not bail making patches if there aren't any.
--
diff --git a/git-debrebase b/git-debrebase
index 3d74d0e..7c69c4c 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -344,7 +344,7 @@ sub gbp_pq_export ($$$) {
{ local ($!,$?); copy('../gbp-pq-err', \*STDERR); }
failedcmd @gbp_cmd;
}
- runcmd @git, qw(add -f debian/patches);
+ runcmd @git, qw(add -f debian/patches) if stat_exists 'debian/patches';
}