summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-11-25 15:12:42 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-11-25 15:12:42 +0000
commit8dd2ab0c514d4e88aa45dad955bf85aa0f713ae0 (patch)
treec0bb89812901cd826b2b937b693b853f779de6bc
parentab3ee70798719db52d33da4f4204fc2943225b7f (diff)
Complain about lack of cuddled values for value-taking single-letter options, rather than thinking the user meat an empty value. Closes:#763332.
-rw-r--r--debian/changelog4
-rwxr-xr-xdgit9
2 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 6152a28..f035107 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -47,6 +47,10 @@ dgit (0.23~) unstable; urgency=low
unconditionally invoke curl and have no code to use wget.
Closes:#760805.
+ * Complain about lack of cuddled values for value-taking single-letter
+ options, rather than thinking the user meat an empty value.
+ Closes:#763332.
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index d936acd..839f93f 100755
--- a/dgit
+++ b/dgit
@@ -2718,17 +2718,20 @@ sub parseopts () {
} elsif (s/^-c(.*=.*)//s) {
push @ropts, $&;
push @git, '-c', $1;
- } elsif (s/^-d(.*)//s) {
+ } elsif (s/^-d(.+)//s) {
push @ropts, $&;
$idistro = $1;
- } elsif (s/^-C(.*)//s) {
+ } elsif (s/^-C(.+)//s) {
push @ropts, $&;
$changesfile = $1;
if ($changesfile =~ s#^(.*)/##) {
$buildproductsdir = $1;
}
- } elsif (s/^-k(.*)//s) {
+ } elsif (s/^-k(.+)//s) {
$keyid=$1;
+ } elsif (m/^-[vdCk]$/) {
+ badusage
+ "option \`$_' requires an argument (and no space before the argument)";
} elsif (s/^-wn//s) {
push @ropts, $&;
$cleanmode = 'none';