summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-31 07:58:15 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-31 07:59:51 +0100
commita2adcd961613b1570dea721391e9f5c9665ba642 (patch)
tree7d2d0236c6bc42394b307710c72a49bbd1b19eec
parent4f753d1e7e9916352bf2f8670f56c1fa20791915 (diff)
git-debrebase: keycommits: Pass correct argument to fail
We got the array index wrong and would print HASH(0x55be4dba1f88) or whatever. Closes:#905003. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rwxr-xr-xgit-debrebase2
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 6124ea7..9d22bed 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (6.3~) unstable; urgency=medium
- *
+ * git-debrebase: breakwater: Fix error message for unprocessable
+ commits. Closes:#905003.
--
diff --git a/git-debrebase b/git-debrebase
index 0c351a4..8385ae4 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -573,7 +573,7 @@ sub keycommits ($;$$$$) {
my ($anchor, $breakwater);
my $clogonly;
my $cl;
- $fatal //= sub { fail $_[2]; };
+ $fatal //= sub { fail $_[1]; };
my $x = sub {
my ($cb, $tagsfx, $mainwhy, $xwhy) = @_;
my $why = $mainwhy.$xwhy;