summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-04-23 01:16:06 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-16 22:40:14 +0100
commitbc95a2402f9e765113ef38d12d642a3340132049 (patch)
treeb7acc849b4af0c4ed330094de8d27f5e2785eeb7
parentd51c2ac366c86d1dd3cc9ac04d5b3b14b1ff23c5 (diff)
dgit: Bail if single-debian-patch needs committing with --quilt=nofix
Also, if the user invokes dgit push with uncommitted debian/patches/. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index b6c60f7..b0fbb92 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ dgit (4.5~) unstable; urgency=medium
* When checking that the tree is clean, check the git index too.
* In quilt_fixup_multipatch, work around git checkout paths
not deleting files. (Hypothetical bug AFAIAA.)
+ * Respect --quilt=nofix even if single-debian-patch.
Minor fixes:
* "confess" when we die due to a warning, rather than symply dieing.
diff --git a/dgit b/dgit
index b43308d..2a581f3 100755
--- a/dgit
+++ b/dgit
@@ -3727,6 +3727,7 @@ sub commit_quilty_patch () {
progress "nothing quilty to commit, ok.";
return;
}
+ quiltify_nofix_bail "", " (wanted to commit patch update)";
my @adds = map { s/[][*?\\]/\\$&/g; $_; } sort keys %adds;
runcmd_ordryrun_local @git, qw(add -f), @adds;
commit_admin <<END