summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-20 23:47:54 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-21 01:11:11 +0100
commitbb9383075fe99dc1a7cb30282f7ae46a967f6e63 (patch)
tree3aaf351b39ce9a644e68513e8ad92b34d33bbc51
parent831a6e07cc5599fdd616dc1eddbabb6d6b5a87a9 (diff)
dgit: commit_quilty_patch: Handle other file statuses too
In particular, R can occur if all Debian changes have been removed in a package with single-debian-patch, in which case we would fail to commit the patch queue removal. I don't think dpkg-source will remove files in other cases, so this is probably the only actually buggy case. I don't think the other letters are particularly likely but if they occur they should be committed too. I have deliberately excluded U which should definitely not occur. Closes:#893263. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 68ec24e..da73430 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,6 +3,8 @@ dgit (5.2~) unstable; urgency=medium
* dgit(1): Mention under `dgit build' that it uses the network.
dgit:
+ * When all Debian changes vanish with single-debian-patch,
+ do not fail to commit the patch queue removal. Closes:#877036.
* When build fails because the network is offline, mention
that this is because --since-version was not specified.
Closes:#883340.
diff --git a/dgit b/dgit
index 9084eaf..1f065dd 100755
--- a/dgit
+++ b/dgit
@@ -3760,7 +3760,7 @@ sub commit_quilty_patch () {
my %adds;
foreach my $l (split /\n/, $output) {
next unless $l =~ m/\S/;
- if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
+ if ($l =~ m{^(?:\?\?| [MADRC]) (.pc|debian/patches)}) {
$adds{$1}++;
}
}