summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 11:33:45 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-23 11:33:45 +0100
commit1d7cbdc7bef6b4752ba0d46b22dd77136c5b3efb (patch)
treebd50476d005a496cb09b5cc58bf490bcd6f46097
parent345e898e30f28ba054f7c417121498a1d6bcf0de (diff)
When generating git tags, quote the (uncanonicalised) changelog's Distribution field as the suite.
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit3
2 files changed, 5 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b8393b1..89f416e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,5 +1,8 @@
dgit (0.17~experimental2) experimental; urgency=low
+ * When generating git tags, quote the (uncanonicalised) changelog's
+ Distribution field as the suite.
+
Changes to remote functionality:
* More bugfixes.
diff --git a/dgit b/dgit
index 0b177d3..5ea9c26 100755
--- a/dgit
+++ b/dgit
@@ -1152,6 +1152,7 @@ sub push_mktag ($$$$$$$) {
}
my $cversion = getfield $clogp, 'Version';
+ my $clogsuite = getfield $clogp, 'Distribution';
# We make the git tag by hand because (a) that makes it easier
# to control the "tagger" (b) we can do remote signing
@@ -1163,7 +1164,7 @@ type commit
tag $tag
tagger $authline
-$package release $cversion for $csuite [dgit]
+$package release $cversion for $clogsuite [dgit]
END
close TO or die $!;