summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-26 18:43:49 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-26 19:20:54 +0100
commit2093c3c0d973b6e9d4b7085ac3084de94550744f (patch)
tree6bc2c87e238a3a82b83df1f2a2e1b5c4847b5f53
parent65c0c0413e6fbd324127090ab55d71b2e5718423 (diff)
git-debrebase new-upstream: Provide better reflog entries
By setting GIT_REFLOG_ACTION. Closes:#901925. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xgit-debrebase2
2 files changed, 4 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 70d600f..0dc3014 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (5.3~) unstable; urgency=medium
Bugfixes:
* Honour GIT_REFLOG_ACTION everywhere. Closes:#901935.
+ * git-debrebase new-upstream: Provide better reflog entries
+ by setting GIT_REFLOG_ACTION. Closes:#901925.
--
diff --git a/git-debrebase b/git-debrebase
index fe11251..658884d 100755
--- a/git-debrebase
+++ b/git-debrebase
@@ -1351,6 +1351,8 @@ END
'launder for new upstream';
my @cmd = (@git, qw(rebase --onto), $new_bw, $old_bw, @ARGV);
+ local $ENV{GIT_REFLOG_ACTION} = git_reflog_action_msg
+ "debrebase new-upstream $new_version: rebase";
runcmd @cmd;
# now it's for the user to sort out
}