summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-01 22:28:29 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-07-01 22:31:38 +0100
commit41a084b412bdfd571a9d48d8e15604dbb72e6470 (patch)
tree87382df78c4cb29186588277c9ebbb772a759a43
parente62698da351bf5e5c97c260544180e4a49cb41ff (diff)
sbuild; Do not pass -A
Incompatible change: * dgit sbuild does not pass -A to sbuild. Consequently the default build is now simply sbuild's default. With older sbuilds it was possible to override dgit's -A by passing another option. But this has been changed recently and now this default setting is very awkward to change for the dgit user.
-rw-r--r--debian/changelog11
-rwxr-xr-xdgit2
2 files changed, 12 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a52b712..a1b56a8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+dgit (1.5~~) unstable; urgency=medium
+
+ Incompatible change:
+ * dgit sbuild does not pass -A to sbuild. Consequently the default
+ build is now simply sbuild's default. With older sbuilds it was
+ possible to override dgit's -A by passing another option. But this
+ has been changed recently and now this default setting is very awkward
+ to change for the dgit user.
+
+ --
+
dgit (1.4) unstable; urgency=high
Bugfixes:
diff --git a/dgit b/dgit
index e02a6bd..9edc657 100755
--- a/dgit
+++ b/dgit
@@ -75,7 +75,7 @@ our (@curl) = qw(curl -f);
our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
our (@gpg) = qw(gpg);
-our (@sbuild) = qw(sbuild -A);
+our (@sbuild) = qw(sbuild);
our (@ssh) = 'ssh';
our (@dgit) = qw(dgit);
our (@dpkgbuildpackage) = qw(dpkg-buildpackage -i\.git/ -I.git);