summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-25 16:04:19 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-25 16:04:20 +0100
commit50419637c2d62d5368a52b6ddb3011f6a75b3b0d (patch)
tree4ff77b2425fea00a1d2397e63616ae0af763dc66
parent69c8de09ff5cb507a7628282d346c2c8fd487a86 (diff)
Test suite: build-mode-*: Check that right .changes comes out.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib-build-modes17
2 files changed, 18 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index f36ae86..615176b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -4,6 +4,7 @@ dgit (2.8~) unstable; urgency=low
being an unusual object, in case dpkg-source doesn't.
* When in split build mode for `gbp-build' or `build', run
mergechanges as is required. Closes:#841990.
+ * Test suite: build-mode-*: Check that right .changes comes out.
--
diff --git a/tests/lib-build-modes b/tests/lib-build-modes
index 00f3a03..30fbb5a 100644
--- a/tests/lib-build-modes
+++ b/tests/lib-build-modes
@@ -143,6 +143,8 @@ bm-compute-expected () {
done
bm-report-test "SOURCE FILE" $e_source
+ bm-report-test "SOURCE IN CHANGES" $e_source
+ bm-report-test "DEBS IN CHANGES" expr "$e_targets" : '.*binary.*'
exec 4>&-
}
@@ -153,6 +155,8 @@ bm-run-one () {
bmid="$act,$cleanmode,$branch"
bmid=${bmid// /_}
+ rm -f ../${p}_{v}_*.changes
+
heading="===== [$bmid] dgit $args ====="
bmlog=$tmp/run.$bmid.output
@@ -194,6 +198,19 @@ bm-run-one () {
bm-report-test "SOURCE FILE" [ -e $dsc ]
+ if [ $actual_status = success ]; then
+ local changes=$(echo ../example_${v}_*.changes)
+ case "$changes" in
+ *' '*) fail "build generated ambiguous .changes: $changes" ;;
+ esac
+
+ perl -ne 'print if m/^files:/i ... m/^\S/' \
+ <$changes >$changes.files
+
+ bm-report-test "SOURCE IN CHANGES" grep '\.dsc$' $changes.files
+ bm-report-test "DEBS IN CHANGES" grep '\.deb$' $changes.files
+ fi
+
exec 4>&-
$bm_quirk_before_diff