summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-16 02:23:26 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-07-16 12:14:46 +0100
commit52b7b05bf7898c0c4c2a4a88fecb4426273ce72d (patch)
tree583ab1f9b15429d3395c4de7056c05e97718c530
parent823fc0fbb11e753520c5cf740bd106a38e775e59 (diff)
dgit-repos-server: Do not reject commits with no author/committer email
But still insist on date, and hence on the actual committer and author commit header fields. Peter Green reports that eg 66c65d90db100435 in upstream linux.git is such a commit (and is accepted by github). Closes:#863353. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog7
-rwxr-xr-xinfra/dgit-repos-server4
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 769fa5c..bbcec9e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,13 @@ dgit (3.12~) unstable; urgency=medium
* dgit import: Right error message for missing files in ..
* dgit import: Avoid making broken symlinks in ..
+ Important bugfixes to other components:
+ * dgit-repos-server: Do not reject commits with no author/committer
+ email address (but still insist on date, and hence on the actual
+ committer and author commit header fields). Peter Green reports that
+ eg 66c65d90db100435 in upstream linux.git is such a commit (and is
+ accepted by github). Closes:#863353.
+
Test suite:
* t-report-fail: print $PWD as part of failure message.
* import-dsc: Test missing files, particularly in ..
diff --git a/infra/dgit-repos-server b/infra/dgit-repos-server
index 55dc81f..ec9b2c9 100755
--- a/infra/dgit-repos-server
+++ b/infra/dgit-repos-server
@@ -902,8 +902,8 @@ sub checks () {
# defend against commits generated by #849041
if (!($policy & NOCOMMITCHECK)) {
- my @checks = qw(%ae %at
- %ce %ct);
+ my @checks = qw(%at
+ %ct);
my @chk = qw(git log -z);
push @chk, '--pretty=tformat:%H%n'.
(join "", map { $_, '%n' } @checks);