summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-01-18 23:35:19 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-01-18 23:35:19 +0000
commit6ac74a9d56fdc86b30c4e7940734cd95be6840c4 (patch)
tree864e01216548017b8300a95451117f454bf9dc3f
parent00ff2e329bed2f77e314381835e3518954ad89d4 (diff)
Do not report the (irrelevant) $? when madison parsing fails.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 6080f8f..aaf0ead 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (0.21~~iwj) unstable; urgency=low
* Use failedcmd to report errors when ssh psql fails. Closes:#734281.
+ * Do not report the (irrelevant) $? when madison parsing fails.
* Add `Testsuite: autopkgtest' to debian/control. (This will only have
the right effect with recent enought dpkg, and will generate a warning
with earlier versions of dpkg.
diff --git a/dgit b/dgit
index 94454d3..19d6b01 100755
--- a/dgit
+++ b/dgit
@@ -636,7 +636,7 @@ sub madison_parse ($) {
$l =~ m{^ \s*( [^ \t|]+ )\s* \|
\s*( [^ \t|]+ )\s* \|
\s*( [^ \t|/]+ )(?:/([^ \t|/]+))? \s* \|
- \s*( [^ \t|]+ )\s* }x or die "$rmad $?";
+ \s*( [^ \t|]+ )\s* }x or die "$rmad ?";
$1 eq $package or die "$rmad $package ?";
my $vsn = $2;
my $newsuite = $3;