summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-04-15 18:08:43 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-05-31 11:54:05 +0100
commit75227f50be6aae4386166de507af1d7fcfcd4823 (patch)
tree889cb166b880e231887e153710dfa937d8bb7485
parenta67d724c1ef3fef7c591a1cf7447cc2c512488ed (diff)
Use ftpmasterapi archive query method. (Closes:#727702.)
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit5
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a5abed6..b925ce7 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -61,6 +61,8 @@ dgit (0.23~) unstable; urgency=low
* Fix inaccurate error message when archive's git hash is not an
ancestor of git repo's git hash.
+ * Use ftpmasterapi archive query method. (Closes:#727702.)
+
--
dgit (0.22.1) unstable; urgency=high
diff --git a/dgit b/dgit
index 661670c..be90450 100755
--- a/dgit
+++ b/dgit
@@ -518,7 +518,7 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit.default.ssh' => 'ssh',
'dgit.default.archive-query' => 'madison:',
'dgit.default.sshpsql-dbname' => 'service=projectb',
- 'dgit-distro.debian.archive-query' => 'sshpsql:',
+ 'dgit-distro.debian.archive-query' => 'ftpmasterapi:',
'dgit-distro.debian.git-host' => 'dgit-git.debian.net',
'dgit-distro.debian.git-user-force' => 'dgit',
'dgit-distro.debian.git-proto' => 'git+ssh://',
@@ -533,7 +533,6 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit-distro.debian/alioth.git-proto' => 'git+ssh://',
'dgit-distro.debian/alioth.git-path' => '/git/dgit-repos/repos',
'dgit-distro.debian/alioth.git-create' => 'ssh-cmd',
- 'dgit-distro.debian.sshpsql-host' => 'mirror.ftp-master.debian.org',
'dgit-distro.debian.upload-host' => 'ftp-master', # for dput
'dgit-distro.debian.mirror' => 'http://ftp.debian.org/debian/',
'dgit-distro.debian.backports-quirk' => '(squeeze)-backports*',
@@ -860,7 +859,7 @@ sub archive_query_ftpmasterapi () {
my $component = "$entry->{component}";
$component =~ m/^$component_re$/ or die "bad component";
my $filename = "$entry->{filename}";
- $filename && $filename !~ m#[^-+:._0-9a-zA-Z/]|^[/.]|/[/.]#
+ $filename && $filename !~ m#[^-+:._~0-9a-zA-Z/]|^[/.]|/[/.]#
or die "bad filename";
my $sha256sum = "$entry->{sha256sum}";
$sha256sum =~ m/^[0-9a-f]+$/ or die "bad sha256sum";