summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 12:04:04 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 13:09:10 +0100
commit7bd0174f7d5a68f77bec94cd64baa5752cf0188a (patch)
tree070c733047feed1ad683f321d992343204762950
parentf710b49b83a617d6cfadf3237d633da3e700793b (diff)
Rename `git-build' operation to `gbp-build' to make it clearer what it's for. Keep the old name as an alias.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit3
-rw-r--r--dgit.14
3 files changed, 6 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index b40be53..bb95fec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -53,6 +53,8 @@ dgit (1.1~~) unstable; urgency=low
trailer line. Closes:#793423.
* Honour --git= (mostly).
* Test suite: More automatic enumeration of tests.
+ * Rename `git-build' operation to `gbp-build' to make it clearer what
+ it's for. Keep the old name as an alias.
--
diff --git a/dgit b/dgit
index b7c6d9a..7377acc 100755
--- a/dgit
+++ b/dgit
@@ -2954,7 +2954,7 @@ sub cmd_build {
printdone "build successful\n";
}
-sub cmd_git_build {
+sub cmd_gbp_build {
build_prep();
my @dbp = @dpkgbuildpackage;
massage_dbp_args \@dbp;
@@ -2969,6 +2969,7 @@ sub cmd_git_build {
runcmd_ordryrun_local @cmd, @ARGV;
printdone "build successful\n";
}
+sub cmd_git_build { cmd_gbp_build(); } # compatibility with <= 1.0
sub build_source {
build_prep();
diff --git a/dgit.1 b/dgit.1
index d73d5b9..88e9812 100644
--- a/dgit.1
+++ b/dgit.1
@@ -134,10 +134,10 @@ in the parent directory will be removed; the output is left in
Tagging, signing and actually uploading should be left to dgit push.
.TP
-\fBdgit git-build\fR ...
+\fBdgit gbp-build\fR ...
Runs
.B git-buildpackage
-with some suitable options. Options and arguments after git-build
+with some suitable options. Options and arguments after gbp-build
will be passed on to git-buildpackage.
Tagging, signing and actually uploading should be left to dgit push.