summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 12:00:38 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-27 13:12:02 +0100
commit94f1626bbddaae07cb56b86dc83a5a5de34f642b (patch)
tree8902afc502e16361be4a54dc1ffe0652f70b2330
parentdbb093b1db7b27bf922f6ad58576cab4fbc342cf (diff)
Also suppress spurious runs of the clean target when building using git-buildpackage.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit7
2 files changed, 8 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 2f29630..7e17a8f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -61,6 +61,8 @@ dgit (1.1~~) unstable; urgency=low
than running it twice. When we are _not_ supposed to be using
dpkg-buildpackage to clean, but we are running it to do the build,
pass -nc.
+ * Also suppress spurious runs of the clean target when building using
+ git-buildpackage.
--
diff --git a/dgit b/dgit
index 22a1ccd..ad460d1 100755
--- a/dgit
+++ b/dgit
@@ -2973,10 +2973,15 @@ sub cmd_build {
sub cmd_gbp_build {
my @dbp = @dpkgbuildpackage;
massage_dbp_args \@dbp;
- build_prep();
my @cmd =
(qw(git-buildpackage -us -uc --git-no-sign-tags),
"--git-builder=@dbp");
+ if ($cleanmode eq 'dpkg-source') {
+ $suppress_clean = 1;
+ } else {
+ push @cmd, '--git-cleaner=true';
+ }
+ build_prep();
unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
canonicalise_suite();
push @cmd, "--git-debian-branch=".lbranch();