summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-09 02:54:27 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-09 13:08:32 +0000
commita1fb6b5478b7189452d1cd2e9098a69fe2db6825 (patch)
tree6c9f207e616021fba56464b9506e655c0e0cd396
parentb0bc4d204e5900c7888e681404e2638ce7347cf9 (diff)
dgit: When generating orig+debian/patches view, copy debian/ from HEAD.
This makes less noise in diffs. Closes:#850095. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit1
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4556644..708c68a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,6 +29,8 @@ dgit (3.0~) unstable; urgency=medium
* Use refs/dgit-fetch/DISTRO rather than refs/dgit-fetch/DISTRO,
which leads to less duplication and so less clutter.
* Enforce a reasonable syntax for nominal distro names.
+ * When generating orig+debian/patches view, copy debian/ from
+ HEAD. This makes less noise in diffs. Closes:#850095.
Docuentation [Sean Whitton]:
* dgit-sponsorship(7): Use --no-dep14tag. Closes:#849105.
diff --git a/dgit b/dgit
index 909ac95..d62694a 100755
--- a/dgit
+++ b/dgit
@@ -5416,6 +5416,7 @@ sub quilt_fixup_multipatch ($$$) {
rmtree '.pc';
+ runcmd @git, qw(checkout -f), $headref, qw(-- debian);
my $unapplied=git_add_write_tree();
printdebug "fake orig tree object $unapplied\n";