summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 01:06:26 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 01:06:27 +0100
commite33153606c256c3298879a108ccb33f8c2554a2d (patch)
tree5b368b389b64beb3a48a9eeca1137eefa4c1064f
parent244a7da76c07975d807da32de824ab3e3ee55478 (diff)
test suite: Fix trustingpolicy-replay & dput-ng.
Specifically: * Only dput-ng actually complains about the existence of .upload files. dput itself just says there is nothing to do and calls that success. * The call to t-rm-dput-dropping was in the wrong place. t-commit bumps the version to 1.1 but it's 1.0 that needs removing. Closes:#903007. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xtests/tests/trustingpolicy-replay3
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 4912f01..6c68113 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,7 @@ dgit (5.7~) unstable; urgency=medium
in the comment about handling patch stacks.
* dgit update-vcs-git: Honour --package properly.
* test suite: Always pass LC_COLLATE=C to sort(1). Closes:#903006.
+ * test suite: Fix trustingpolicy-replay & dput-ng. Closes:#903007.
--
diff --git a/tests/tests/trustingpolicy-replay b/tests/tests/trustingpolicy-replay
index ad731f5..e56ec7b 100755
--- a/tests/tests/trustingpolicy-replay
+++ b/tests/tests/trustingpolicy-replay
@@ -17,11 +17,12 @@ git tag start
t-dgit build
t-dgit push --new
+t-rm-dput-dropping
+
t-commit 'Prep v1.1 which will be rewound'
t-dgit build
t-dgit push
-t-rm-dput-dropping
git checkout $tagpfx/1.0
t-dgit build
t-dgit push --deliberately-fresh-repo