summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 00:15:44 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-07-05 00:15:48 +0100
commit61f92b326da0efea1cf4d3c263ef0e0b7cacfc25 (patch)
treef186a790a765a894c20ec0f2bae9126df067dac1
parent80489b3ec6643c06d525ec39a7d72135286ba62c (diff)
test suite: Always pass LC_COLLATE=C to sort(1).
Specifically, by replacing every invocation of sort with the new function t-sort. The one case where we already took care of this, we change LC_ALL to LC_COLLATE, which should be sufficient. Closes:#903006. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib2
-rw-r--r--tests/lib-core4
-rw-r--r--tests/lib-gdr2
-rw-r--r--tests/lib-import-chk8
-rwxr-xr-xtests/tartree-edit2
-rwxr-xr-xtests/tests/checkout2
-rwxr-xr-xtests/tests/import-native2
-rwxr-xr-xtests/tests/manpages-format2
9 files changed, 15 insertions, 10 deletions
diff --git a/debian/changelog b/debian/changelog
index dcff9e6..4912f01 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,7 @@ dgit (5.7~) unstable; urgency=medium
* dgit(7): Mention git-debrebase and gbp pq alongside git-dpm,
in the comment about handling patch stacks.
* dgit update-vcs-git: Honour --package properly.
+ * test suite: Always pass LC_COLLATE=C to sort(1). Closes:#903006.
--
diff --git a/tests/lib b/tests/lib
index bad47c9..4ef275c 100644
--- a/tests/lib
+++ b/tests/lib
@@ -153,7 +153,7 @@ t-reporefs () {
exec >"$outputfile"
if test -d $whichrepo; then
cd $whichrepo
- git show-ref |sort
+ git show-ref |t-sort
fi)
}
diff --git a/tests/lib-core b/tests/lib-core
index e2b6c06..724c8ac 100644
--- a/tests/lib-core
+++ b/tests/lib-core
@@ -40,3 +40,7 @@ t-filter-out-git-hyphen-dir () {
path="${path%:}"
PATH="$path"
}
+
+t-sort () {
+ LC_COLLATE=C sort "$@"
+}
diff --git a/tests/lib-gdr b/tests/lib-gdr
index 7b4f085..22ea6d1 100644
--- a/tests/lib-gdr
+++ b/tests/lib-gdr
@@ -141,7 +141,7 @@ t-gdr-good () {
test $cnparents = $enparents
local cndparents=`
- for f in $parents; do echo $f; done | sort -u | wc -w
+ for f in $parents; do echo $f; done | t-sort -u | wc -w
`
test $cndparents = $cnparents
diff --git a/tests/lib-import-chk b/tests/lib-import-chk
index 88984c1..d6633f9 100644
--- a/tests/lib-import-chk
+++ b/tests/lib-import-chk
@@ -1,11 +1,11 @@
t-import-chk-authorship () {
perl -ne 'print $1,"\n" if m/^ -- (\S.*\>) /' debian/changelog \
- | sort -u \
+ | t-sort -u \
> $tmp/authorship.changelog
${import_chk_changelog_massage:-:} $tmp/authorship.changelog
git log --pretty=format:'%an <%ae>%n%cn <%ce>' \
- | sort -u \
+ | t-sort -u \
> $tmp/authorship.commits
diff $tmp/authorship.{changelog,commits}
}
@@ -63,7 +63,7 @@ t-import-chk2() {
t-ref-same refs/heads/first-2nd-import
for orig in ../${p}_${v%-*}.orig*.tar.*; do
- tar -atf $orig | LC_ALL=C sort >../files.o
+ tar -atf $orig | t-sort >../files.o
pfx=$(perl <../files.o -ne '
while (<>) {
m#^([^/]+/)# or exit 0;
@@ -87,7 +87,7 @@ t-import-chk2() {
t-ref-same-val "$orig $start" "$imp"
done
git ls-tree -r --name-only "$t_ref_val:" \
- | sort >../files.g
+ | t-sort >../files.g
diff ../files.{o,g}
done
cd ..
diff --git a/tests/tartree-edit b/tests/tartree-edit
index 40bd6e9..78f0e4f 100755
--- a/tests/tartree-edit
+++ b/tests/tartree-edit
@@ -17,7 +17,7 @@ gitfetchdiff_list () {
git for-each-ref --format '%(refname) %(objectname)' \
refs/remotes/"$1" \
| sed 's/^refs\/remotes\/[^\/]*\///' \
- | sort >"$play/$2"
+ | t-sort >"$play/$2"
}
gitfetchdiff () {
diff --git a/tests/tests/checkout b/tests/tests/checkout
index 4b205f3..bc3d6ef 100755
--- a/tests/tests/checkout
+++ b/tests/tests/checkout
@@ -39,7 +39,7 @@ dgit checkout unstable
END
diff -u ../reflog.{expect,got}
-git for-each-ref --format='%(refname)' refs/heads | sort >../refs.got
+git for-each-ref --format='%(refname)' refs/heads | t-sort >../refs.got
cat >../refs.expect <<END
refs/heads/dgit/sid
refs/heads/dgit/stable
diff --git a/tests/tests/import-native b/tests/tests/import-native
index 1e09343..0766841 100755
--- a/tests/tests/import-native
+++ b/tests/tests/import-native
@@ -8,7 +8,7 @@ t-tstunt-parsechangelog
mkdir $tmp/aside
versions=""
-for f in $(find $tmp/mirror -name \*.dsc | sort); do
+for f in $(find $tmp/mirror -name \*.dsc | t-sort); do
perl -i -pe '
$_="" if m/^-----BEGIN PGP SIGNED/..!m/\S/;
$_="" if m/^-----BEGIN PGP SIGNATURE/..0;
diff --git a/tests/tests/manpages-format b/tests/tests/manpages-format
index 3f3362b..7ba2f9d 100755
--- a/tests/tests/manpages-format
+++ b/tests/tests/manpages-format
@@ -7,7 +7,7 @@ t-dependencies man-db make groff git-debrebase
cd $root
-printenv |grep MAKE ||: |sort
+printenv |grep MAKE ||: |t-sort
manpages=$(MAKEFLAGS= MAKELEVEL= make list-manpages)
export MANWIDTH=80