summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-22 11:22:12 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-22 13:23:04 +0100
commit6747e1e6b33857b9cc9d1051c5bbee087ccf833e (patch)
treec802febd603e8bef1297d71956d3c61380771035
parent727e940a12fb2e890377075ae59953a5524b93ea (diff)
quilt-fixup checks that the git tree is clean, as for build-prep.
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 831973f..564ccc3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,7 @@ dgit (1.4~~) UNRELEASED; urgency=low
the user can override it. Closes:#796019.
* Test suite: run quilt-fixup with -wgf in distropatches-reject,
so that we don't need build-depends.
+ * quilt-fixup checks that the git tree is clean, as for build-prep.
--
diff --git a/dgit b/dgit
index dbb0a06..e02a6bd 100755
--- a/dgit
+++ b/dgit
@@ -3161,6 +3161,8 @@ sub cmd_quilt_fixup {
my $clogp = parsechangelog();
$version = getfield $clogp, 'Version';
$package = getfield $clogp, 'Source';
+ check_not_dirty();
+ clean_tree();
build_maybe_quilt_fixup();
}