summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-07 13:23:28 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-07 13:23:29 +0000
commit7a3361bb3c0dab34d001bcda1c56ec42aec6e8b3 (patch)
treedb573820d16e70653b9912ec7ebde5fe4857c4d2
parent014f97da094a9fcf874778410d96b80d26a4bf95 (diff)
dgit-badcommit-fixup: Fix crash when running for 2nd time in bare repo.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog5
-rwxr-xr-xdgit-badcommit-fixup2
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index fb10d5e..4a13463 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
-dgit (2.17~) unstable; urgency=medium
+dgit (2.16.2~) unstable; urgency=medium
- *
+ dgit-badcommit-fixup:
+ * Fix crash when running for 2nd time in bare repo.
--
diff --git a/dgit-badcommit-fixup b/dgit-badcommit-fixup
index a9a8f60..935f5df 100755
--- a/dgit-badcommit-fixup
+++ b/dgit-badcommit-fixup
@@ -231,7 +231,7 @@ foreach my $rline (split /\n/, $refs) {
or die "$_ ?";
if ($refname eq 'refs/dgit-rewrite/map') {
$org_rewrite_map = $obj;
- continue;
+ next;
}
next if $refname =~ m{^refs/dgit-(?:badcommit|badfixuptest)/};
my $rewrite;