summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-13 16:21:11 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-10-13 16:46:47 +0100
commitbaa9de40ad22d98b51959054a50e46b2456d33d5 (patch)
tree114c1213d6ef188dea022f6507c9b93f73371dbc
parent4d40038a08552bc4340b603169fdf5da13473e41 (diff)
test suite: push-source-with-changes: Make it test -wdda
We have plenty of other places where we used -wddn or ,no-check. Here we have an opportunity to test -wdda: create a ~ file (which would be ignored), clean everything else, and check that -wdda fails but the default (-wdd) succeds. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rwxr-xr-xtests/tests/push-source-with-changes9
1 files changed, 8 insertions, 1 deletions
diff --git a/tests/tests/push-source-with-changes b/tests/tests/push-source-with-changes
index 2a123c3..aed1b63 100755
--- a/tests/tests/push-source-with-changes
+++ b/tests/tests/push-source-with-changes
@@ -23,7 +23,14 @@ t-dgit -C ../${p}_1.0_multi.changes push-source --new
t-expect-fail F:'tree contains uncommitted files' \
t-dgit build-source
-t-dgit -wddn build-source
+cp debian/rules{,~}
+git clean -df
+ls debian/rules~
+
+t-expect-fail F:'tree contains uncommitted files' \
+t-dgit -wdda build-source
+
+t-dgit build-source
t-dgit -C ../${p}_1.0_source.changes push-source --new
t-pushed-good master