summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-28 23:18:52 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-28 23:18:52 +0100
commitd1c14131ff8c1e9e0b0b005cb065a952b6631e3c (patch)
tree6f33308d8ee39e05569a0b2582804ef73e8d888e
parentfc461931e5316cbd9cad4a93b9bbac3ad69c81a4 (diff)
parent28789232f5edcc1c24bbb4bfe3b5e12119e9886e (diff)
Merge branch 'master' of git+ssh://git.debian.org/git/dgit-repos/repos/dgit into dgit/experimental
Conflicts: debian/changelog
-rw-r--r--debian/changelog67
-rw-r--r--debian/control5
-rwxr-xr-xdgit362
-rw-r--r--dgit.1166
4 files changed, 480 insertions, 120 deletions
diff --git a/debian/changelog b/debian/changelog
index 4cb6d32..f881d74 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,70 @@
+dgit (0.13) unstable; urgency=low
+
+ * Reuse already-downloaded .orig files after checking their hashes.
+ Closes: #720526. (This introduces a dependency on the Digest::SHA.)
+ * Do not always pointlessly fetch the .dsc twice. (That code was
+ erroneously duplicated during editing, apparently.)
+ * Remove DGET_UNPACK from the environment in case the user has set it.
+ * Remove scary warning from Description.
+
+ --
+
+dgit (0.12) unstable; urgency=low
+
+ * Cope with packages with epoch. Closes: #720897.
+ * Improve error message for non-fast-forward push. Closes: #720896.
+ * New --ignore-dirty option to skip noncritical check. Closes: #720895.
+ * New --no-quilt-fixup option to suppress quilt fixup. RTFM.
+ * Add Closes line for #720595 to changelog entry for 0.11.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Mon, 26 Aug 2013 16:50:39 +0100
+
+dgit (0.11) unstable; urgency=low
+
+ * Location of dgit-repos is now git.debian.org:/git/dgit-repos/repos.
+ Closes: #720525. The rename on the server side will break older
+ versions of dgit.
+ * Fix bug which would make quilt patch fixup fail if git status
+ produced "M" lines.
+ * Autogenerated quilt patch fixup patch Description contains several
+ recent git commits, rather than implying that the patch corresponds
+ exactly to the top git commit.
+ * Use "ftp.debian.org" not "http.debian.net" as the default Debian
+ archive. (http.debian.net tends to defeat certain kinds of cacheing,
+ and can also have more skew.)
+ * dgit build uses dpkg-buildpackage; there is a dgit git-build
+ for using git-buildpackage. Closes: #720595.
+ * Better error message for use of UNRELEASED suite. Closes: #720523.
+ * Do not canonicalise suite more than once. Related to: #720526.
+ * Fix a badly open-coded copy of check_not_dirty. Closes: #720524.
+ * Fix some bugs in building (eg build-source would fail to do the quilt
+ fixup; the --clean check in build was wrong).
+ * Add missing dependency on realpath.
+ * git-build (git-buildpackage wrapper) does not bother canonicalising
+ the suite if --git-ignore-branch is used.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 25 Aug 2013 17:00:43 +0100
+
+dgit (0.10) unstable; urgency=low
+
+ * Create .pc/applied-patches - do not empty it (!)
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sun, 25 Aug 2013 00:51:50 +0100
+
+dgit (0.9) unstable; urgency=low
+
+ * New cleaning arrangements.
+ * More comprehensive workaround for `3.0 (quilt)'.
+ * In push, double-check the .changes against the changelog.
+ * Better error when source package contains .git. Closes: #720555.
+ * Change our .dsc field name to `Dgit'. Relevant to #720201.
+ * Fix bug handling our synthetic merges when we see them in
+ the remote suite branch.
+ * `3.0 (quilt)' fixup creates .pc/applied-patches since modern
+ dpkg-source creates it even though old ones didn't always.
+
+ -- Ian Jackson <ijackson@chiark.greenend.org.uk> Sat, 24 Aug 2013 18:49:02 +0100
+
dgit (0.8+nmu1) experimental; urgency=low
* Non-maintainer upload.
diff --git a/debian/control b/debian/control
index 258cc23..8f15413 100644
--- a/debian/control
+++ b/debian/control
@@ -7,7 +7,7 @@ Build-Depends: debhelper (>= 9)
Package: dgit
Depends: perl, libwww-perl, libdpkg-perl, git-core, devscripts, dpkg-dev,
- ${misc:Depends}
+ ${misc:Depends}, realpath, libdigest-sha-perl
Recommends: ssh-client
Suggests: sbuild
Architecture: all
@@ -18,6 +18,3 @@ Description: git interoperability with the Debian archive
dgit push constructs uploads from git commits
.
dgit clone and dgit fetch construct git commits from uploads.
- .
- WARNING: This program is INCOMPLETE and WRONG and should not yet
- be used. It is being uploaded to facilitate development.
diff --git a/dgit b/dgit
index f9c46c0..9d1570c 100755
--- a/dgit
+++ b/dgit
@@ -24,6 +24,7 @@ use Data::Dumper;
use LWP::UserAgent;
use Dpkg::Control::Hash;
use File::Path;
+use File::Basename;
use Dpkg::Version;
use POSIX;
@@ -35,7 +36,10 @@ our $sign = 1;
our $dryrun = 0;
our $changesfile;
our $new_package = 0;
+our $ignoredirty = 0;
+our $noquilt = 0;
our $existing_package = 'dpkg';
+our $cleanmode = 'dpkg-source';
our %format_ok = map { $_=>1 } ("1.0","3.0 (native)","3.0 (quilt)");
@@ -45,14 +49,19 @@ our (@dput) = qw(dput);
our (@debsign) = qw(debsign);
our (@sbuild) = qw(sbuild -A);
our (@dpkgbuildpackage) = qw(dpkg-buildpackage -i\.git/ -I.git);
+our (@dpkgsource) = qw(dpkg-source -i\.git/ -I.git);
+our (@dpkggenchanges) = qw(dpkg-genchanges);
our (@mergechanges) = qw(mergechanges -f);
-
+our (@changesopts) = ('');
our %opts_opt_map = ('dget' => \@dget,
'dput' => \@dput,
'debsign' => \@debsign,
'sbuild' => \@sbuild,
+ 'dpkg-source' => \@dpkgsource,
'dpkg-buildpackage' => \@dpkgbuildpackage,
+ 'dpkg-genchanges' => \@dpkggenchanges,
+ 'ch' => \@changesopts,
'mergechanges' => \@mergechanges);
our $keyid;
@@ -61,7 +70,7 @@ our $debug = 0;
open DEBUG, ">/dev/null" or die $!;
our $remotename = 'dgit';
-our $ourdscfield = 'Vcs-Dgit-Master';
+our @ourdscfield = qw(Dgit Vcs-Dgit-Master);
our $branchprefix = 'dgit';
our $csuite;
@@ -76,7 +85,18 @@ sub debiantag ($) {
return "debian/$v";
}
-sub dscfn ($) { return "${package}_$_[0].dsc"; }
+sub stripepoch ($) {
+ my ($vsn) = @_;
+ $vsn =~ s/^\d+\://;
+ return $vsn;
+}
+
+sub dscfn ($) {
+ my ($vsn) = @_;
+ return "${package}_".(stripepoch $vsn).".dsc";
+}
+
+sub changesopts () { return @changesopts[1..$#changesopts]; }
our $us = 'dgit';
@@ -221,13 +241,13 @@ our %defcfg = ('dgit.default.distro' => 'debian',
'dgit.default.ssh' => 'ssh',
'dgit-distro.debian.git-host' => 'git.debian.org',
'dgit-distro.debian.git-proto' => 'git+ssh://',
- 'dgit-distro.debian.git-path' => '/git/dgit-repos',
+ 'dgit-distro.debian.git-path' => '/git/dgit-repos/repos',
'dgit-distro.debian.git-check' => 'ssh-cmd',
'dgit-distro.debian.git-create' => 'ssh-cmd',
'dgit-distro.debian.sshdakls-host' => 'coccia.debian.org',
'dgit-distro.debian.sshdakls-dir' =>
'/srv/ftp-master.debian.org/ftp/dists',
- 'dgit-distro.debian.mirror' => 'http://http.debian.net/debian/');
+ 'dgit-distro.debian.mirror' => 'http://ftp.debian.org/debian/');
sub cfg {
foreach my $c (@_) {
@@ -390,7 +410,7 @@ sub madison_parse ($) {
}
$5 eq 'source' or die "$rmad ?";
my $prefix = substr($package, 0, $package =~ m/^l/ ? 4 : 1);
- my $subpath = "/pool/$component/$prefix/$package/${package}_$vsn.dsc";
+ my $subpath = "/pool/$component/$prefix/$package/".dscfn($vsn);
push @out, [$vsn,$subpath,$newsuite];
}
return sort { -version_compare_string($a->[0],$b->[0]); } @out;
@@ -406,6 +426,8 @@ sub canonicalise_suite_madison ($$) {
}
sub canonicalise_suite () {
+ return if defined $csuite;
+ fail "cannot operate on $isuite suite" if $isuite eq 'UNRELEASED';
$csuite = archive_query('canonicalise_suite');
if ($isuite ne $csuite) {
# madison canonicalises for us
@@ -421,8 +443,6 @@ sub get_archive_dsc () {
$dscurl = access_cfg('mirror').$subpath;
$dscdata = url_get($dscurl);
next unless defined $dscdata;
- $dscurl = access_cfg('mirror').$subpath;
- $dscdata = url_get($dscurl);
my $dscfh = new IO::File \$dscdata, '<' or die $!;
print DEBUG Dumper($dscdata) if $debug>1;
$dsc = parsecontrolfh($dscfh,$dscurl, allow_pgp=>1);
@@ -479,7 +499,7 @@ sub mktree_in_ud_from_only_subdir () {
$dirs[0] =~ m#^([^/]+)/\.$# or die;
my $dir = $1;
chdir $dir or die "$dir $!";
- die if stat '.git';
+ fail "source package contains .git directory" if stat '.git';
die $! unless $!==&ENOENT;
runcmd qw(git init -q);
rmtree('.git/objects');
@@ -490,16 +510,35 @@ sub mktree_in_ud_from_only_subdir () {
return ($tree,$dir);
}
-sub dsc_files () {
- my $field = $dsc->{'Checksums-Sha256'} || $dsc->{Files};
- defined $field or
- fail "missing both Checksums-Sha256 and Files in ".
+sub dsc_files_info () {
+ foreach my $csumi (['Checksums-Sha256','Digest::SHA', 'new(256)'],
+ ['Checksums-Sha1', 'Digest::SHA', 'new(1)'],
+ ['Files', 'Digest::MD5', 'new()']) {
+ my ($fname, $module, $method) = @$csumi;
+ my $field = $dsc->{$fname};
+ next unless defined $field;
+ eval "use $module; 1;" or die $@;
+ my @out;
+ foreach (split /\n/, $field) {
+ next unless m/\S/;
+ m/^(\w+) (\d+) (\S+)$/ or
+ fail "could not parse .dsc $fname line \`$_'";
+ my $digester = eval "$module"."->$method;" or die $@;
+ push @out, {
+ Hash => $1,
+ Bytes => $2,
+ Filename => $3,
+ Digester => $digester,
+ };
+ }
+ return @out;
+ }
+ fail "missing any supported Checksums-* or Files field in ".
$dsc->get_option('name');
- map {
- m/^\w+ \d+ (\S+)$/ or
- fail "could not parse .dsc Files/Checksums line \`$_'";
- $1;
- } grep m/\S/, split /\n/, $field;
+}
+
+sub dsc_files () {
+ map { $_->{Filename} } dsc_files_info();
}
sub is_orig_file ($) {
@@ -582,12 +621,9 @@ Last allegedly pushed/uploaded: $oversion (newer or same)
$later_warning_msg
END
$outputhash = $upload_hash;
- } elsif ($outputhash ne $upload_hash) {
- fail "version in archive ($cversion)".
- " is same as version in git".
- " to-be-uploaded (upload/) branch ($oversion)".
- " but archive version hash no commit hash?!";
- }
+ } else {
+ $outputhash = $upload_hash;
+ }
}
chdir '../../../..' or die $!;
runcmd @git, qw(update-ref -m),"dgit fetch import $cversion",
@@ -599,10 +635,20 @@ END
}
sub ensure_we_have_orig () {
- foreach my $f (dsc_files()) {
+ foreach my $fi (dsc_files_info()) {
+ my $f = $fi->{Filename};
next unless is_orig_file($f);
- if (stat "../$f") {
- die "$f ?" unless -f _;
+ if (open F, "<", "../$f") {
+ $fi->{Digester}->reset();
+ $fi->{Digester}->addfile(*F);
+ F->error and die $!;
+ my $got = $fi->{Digester}->hexdigest();
+ $got eq $fi->{Hash} or
+ fail "existing file $f has hash $got but .dsc".
+ " demands hash $fi->{Hash}".
+ " (perhaps you should delete this file?)";
+ print "using existing $f\n";
+ next;
} else {
die "$f $!" unless $!==&ENOENT;
}
@@ -622,8 +668,14 @@ sub rev_parse ($) {
sub is_fast_fwd ($$) {
my ($ancestor,$child) = @_;
- my $mb = cmdoutput @git, qw(merge-base), $ancestor, $child;
- return rev_parse($mb) eq rev_parse($ancestor);
+ my @cmd = (@git, qw(merge-base), $ancestor, $child);
+ my $mb = cmdoutput_errok @cmd;
+ if (defined $mb) {
+ return rev_parse($mb) eq rev_parse($ancestor);
+ } else {
+ $?==256 or failedcmd @cmd;
+ return 0;
+ }
}
sub git_fetch_us () {
@@ -635,7 +687,10 @@ sub fetch_from_archive () {
# ensures that lrref() is what is actually in the archive,
# one way or another
get_archive_dsc() or return 0;
- $dsc_hash = $dsc->{$ourdscfield};
+ foreach my $field (@ourdscfield) {
+ $dsc_hash = $dsc->{$field};
+ last if defined $dsc_hash;
+ }
if (defined $dsc_hash) {
$dsc_hash =~ m/\w+/ or fail "invalid hash in .dsc \`$dsc_hash'";
$dsc_hash = $&;
@@ -737,6 +792,7 @@ sub pull () {
}
sub check_not_dirty () {
+ return if $ignoredirty;
my @cmd = (@git, qw(diff --quiet HEAD));
printcmd(\*DEBUG,"+",@cmd) if $debug>0;
$!=0; $?=0; system @cmd;
@@ -748,24 +804,39 @@ sub check_not_dirty () {
}
}
-sub commit_quilty_patch ($) {
- my ($vsn) = @_;
+sub commit_quilty_patch () {
my $output = cmdoutput @git, qw(status --porcelain);
- my %fixups = map {$_=>1}
- (".pc/debian-changes-$vsn/","debian/patches/debian-changes-$vsn");
- my @files;
+ my %adds;
+ my $bad=0;
foreach my $l (split /\n/, $output) {
- next unless $l =~ s/^\?\? //;
- next unless $fixups{$l};
- push @files, $l;
+ next unless $l =~ m/\S/;
+ if ($l =~ m{^(?:\?\?| M) (.pc|debian/patches)}) {
+ $adds{$1}++;
+ } else {
+ print STDERR "git status: $l\n";
+ $bad++;
+ }
+ }
+ fail "unexpected output from git status (is tree clean?)" if $bad;
+ if (!%adds) {
+ print "nothing quilty to commit, ok.\n";
+ return;
}
- print DEBUG "checking for quilty\n", Dumper(\@files);
- if (@files == 2) {
- my $m = "Commit Debian 3.0 (quilt) metadata";
- print "$m\n";
- runcmd_ordryrun @git, qw(add), @files;
- runcmd_ordryrun @git, qw(commit -m), $m;
+ runcmd_ordryrun @git, qw(add), sort keys %adds;
+ my $m = "Commit Debian 3.0 (quilt) metadata";
+ print "$m\n";
+ runcmd_ordryrun @git, qw(commit -m), $m;
+}
+
+sub madformat ($) {
+ my ($format) = @_;
+ return 0 unless $format eq '3.0 (quilt)';
+ print "Format \`$format', urgh\n";
+ if ($noquilt) {
+ print "Not doing any fixup of \`$format' due to --no-quilt-fixup";
+ return 0;
}
+ return 1;
}
sub dopush () {
@@ -785,9 +856,8 @@ sub dopush () {
fail "$dsc is for $dscpackage $dversion".
" but debian/changelog is for $package $cversion";
print DEBUG "format $format\n";
- if ($format eq '3.0 (quilt)') {
- print "Format \`$format', urgh\n";
- commit_quilty_patch($dversion);
+ if (madformat($format)) {
+ commit_quilty_patch();
}
check_not_dirty();
prep_ud();
@@ -813,15 +883,15 @@ sub dopush () {
# runcmd @git, qw(fetch -p ), "$alioth_git/$package.git",
# map { lref($_).":".rref($_) }
# (uploadbranch());
- $dsc->{$ourdscfield} = rev_parse('HEAD');
+ $dsc->{$ourdscfield[0]} = rev_parse('HEAD');
$dsc->save("../$dscfn.tmp") or die $!;
if (!$changesfile) {
- my $multi = "../${package}_${cversion}_multi.changes";
+ my $multi = "../${package}_".(stripepoch $cversion)."_multi.changes";
if (stat "$multi") {
$changesfile = $multi;
} else {
$!==&ENOENT or die "$multi: $!";
- my $pat = "${package}_${cversion}_*.changes";
+ my $pat = "${package}_".(stripepoch $cversion)."_*.changes";
my @cs = glob "../$pat";
fail "failed to find unique changes file".
" (looked for $pat in .., or $multi);".
@@ -830,6 +900,12 @@ sub dopush () {
($changesfile) = @cs;
}
}
+ my $changes = parsecontrol($changesfile,$changesfile);
+ foreach my $field (qw(Source Distribution Version)) {
+ $changes->{$field} eq $clogp->{$field} or
+ fail "changes field $field \`$changes->{$field}'".
+ " does not match changelog \`$clogp->{$field}'";
+ }
my $tag = debiantag($dversion);
if (!check_for_git()) {
create_remote_git_repo();
@@ -926,7 +1002,7 @@ sub cmd_pull {
sub cmd_push {
parseopts();
badusage "-p is not allowed with dgit push" if defined $package;
- runcmd @git, qw(diff --quiet HEAD);
+ check_not_dirty();
my $clogp = parsechangelog();
$package = getfield $clogp, 'Source';
if (@ARGV==0) {
@@ -942,7 +1018,10 @@ sub cmd_push {
git_fetch_us();
}
if (fetch_from_archive()) {
- is_fast_fwd(lrref(), 'HEAD') or die;
+ is_fast_fwd(lrref(), 'HEAD') or
+ fail "dgit push: HEAD is not a descendant".
+ " of the archive's version.\n".
+ "$us: To overwrite it, use git-merge -s ours ".lrref().".";
} else {
$new_package or
fail "package appears to be new in this suite;".
@@ -951,35 +1030,149 @@ sub cmd_push {
dopush();
}
-sub cmd_build {
- # we pass further options and args to git-buildpackage
- badusage "-p is not allowed with dgit build" if defined $package;
+our $version;
+our $sourcechanges;
+our $dscfn;
+
+our $fakeeditorenv = 'DGIT_FAKE_EDITOR_QUILT';
+
+sub build_maybe_quilt_fixup () {
+ if (!open F, "debian/source/format") {
+ die $! unless $!==&ENOENT;
+ return;
+ }
+ $_ = <F>;
+ F->error and die $!;
+ chomp;
+ return unless madformat($_);
+ # sigh
+ my $clogp = parsechangelog();
+ my $version = getfield $clogp, 'Version';
+ my $author = getfield $clogp, 'Maintainer';
+ my $headref = rev_parse('HEAD');
+ my $time = time;
+ my $ncommits = 3;
+ my $patchname = "auto-$version-$headref-$time";
+ my $msg = cmdoutput @git, qw(log), "-n$ncommits";
+ my $descfn = ".git/dgit/quilt-description.tmp";
+ open O, '>', $descfn or die "$descfn: $!";
+ $msg =~ s/\n/\n /g;
+ $msg =~ s/^\s+$/ ./mg;
+ print O <<END or die $!;
+Description: Automatically generated patch ($clogp->{Version})
+ Last (up to) $ncommits git changes, FYI:
+ .
+ $msg
+Author: $author
+
+---
+
+END
+ close O or die $!;
+ {
+ local $ENV{'EDITOR'} = cmdoutput qw(realpath --), $0;
+ local $ENV{'VISUAL'} = $ENV{'EDITOR'};
+ local $ENV{$fakeeditorenv} = cmdoutput qw(realpath --), $descfn;
+ runcmd_ordryrun @dpkgsource, qw(--commit .), $patchname;
+ }
+
+ if (!open P, '>>', ".pc/applied-patches") {
+ $!==&ENOENT or die $!;
+ } else {
+ close P;
+ }
+
+ commit_quilty_patch();
+}
+
+sub quilt_fixup_editor () {
+ my $descfn = $ENV{$fakeeditorenv};
+ my $editing = $ARGV[$#ARGV];
+ open I1, '<', $descfn or die "$descfn: $!";
+ open I2, '<', $editing or die "$editing: $!";
+ unlink $editing or die "$editing: $!";
+ open O, '>', $editing or die "$editing: $!";
+ while (<I1>) { print O or die $!; } I1->error and die $!;
+ my $copying = 0;
+ while (<I2>) {
+ $copying ||= m/^\-\-\- /;
+ next unless $copying;
+ print O or die $!;
+ }
+ I2->error and die $!;
+ close O or die $1;
+ exit 0;
+}
+
+sub build_prep () {
+ badusage "-p is not allowed when building" if defined $package;
+ check_not_dirty();
my $clogp = parsechangelog();
$isuite = getfield $clogp, 'Distribution';
$package = getfield $clogp, 'Source';
+ $version = getfield $clogp, 'Version';
+ build_maybe_quilt_fixup();
+}
+
+sub cmd_build {
+ badusage "dgit build implies --clean=dpkg-source"
+ if $cleanmode ne 'dpkg-source';
+ build_prep();
+ runcmd_ordryrun @dpkgbuildpackage, qw(-us -uc), changesopts(), @ARGV;
+ printdone "build successful\n";
+}
+
+sub cmd_git_build {
+ badusage "dgit git-build implies --clean=dpkg-source"
+ if $cleanmode ne 'dpkg-source';
+ build_prep();
my @cmd =
(qw(git-buildpackage -us -uc --git-no-sign-tags),
"--git-builder=@dpkgbuildpackage");
- unless (grep { m/^--git-debian-branch/ } @ARGV) {
+ unless (grep { m/^--git-debian-branch|^--git-ignore-branch/ } @ARGV) {
canonicalise_suite();
push @cmd, "--git-debian-branch=".lbranch();
}
+ push @cmd, changesopts();
runcmd_ordryrun @cmd, @ARGV;
printdone "build successful\n";
}
+sub build_source {
+ build_prep();
+ $sourcechanges = "${package}_".(stripepoch $version)."_source.changes";
+ $dscfn = dscfn($version);
+ if ($cleanmode eq 'dpkg-source') {
+ runcmd_ordryrun (@dpkgbuildpackage, qw(-us -uc -S)), changesopts();
+ } else {
+ if ($cleanmode eq 'git') {
+ runcmd_ordryrun @git, qw(clean -xdf);
+ } elsif ($cleanmode eq 'none') {
+ } else {
+ die "$cleanmode ?";
+ }
+ my $pwd = cmdoutput qw(env - pwd);
+ my $leafdir = basename $pwd;
+ chdir ".." or die $!;
+ runcmd_ordryrun @dpkgsource, qw(-b --), $leafdir;
+ chdir $pwd or die $!;
+ runcmd_ordryrun qw(sh -ec),
+ 'exec >$1; shift; exec "$@"','x',
+ "../$sourcechanges",
+ @dpkggenchanges, qw(-S), changesopts();
+ }
+}
+
+sub cmd_build_source {
+ badusage "build-source takes no additional arguments" if @ARGV;
+ build_source();
+ printdone "source built, results in $dscfn and $sourcechanges";
+}
+
sub cmd_sbuild {
- check_not_dirty();
- badusage "-p is not allowed with dgit sbuild" if defined $package;
- my $clogp = parsechangelog();
- $package = getfield $clogp, 'Source';
- my $isuite = getfield $clogp, 'Distribution';
- my $version = getfield $clogp, 'Version';
- runcmd_ordryrun (@dpkgbuildpackage, qw(-us -uc -S));
+ build_source();
chdir ".." or die $!;
- my $sourcechanges = "${package}_${version}_source.changes";
- my $dscfn = dscfn($version);
- my $pat = "${package}_${version}_*.changes";
+ my $pat = "${package}_".(stripepoch $version)."_*.changes";
if (!$dryrun) {
stat $dscfn or fail "$dscfn (in parent directory): $!";
stat $sourcechanges or fail "$sourcechanges (in parent directory): $!";
@@ -990,7 +1183,7 @@ sub cmd_sbuild {
}
runcmd_ordryrun @sbuild, @ARGV, qw(-d), $isuite, $dscfn;
runcmd_ordryrun @mergechanges, glob $pat;
- my $multichanges = "${package}_${version}_multi.changes";
+ my $multichanges = "${package}_".(stripepoch $version)."_multi.changes";
if (!$dryrun) {
stat $multichanges or fail "$multichanges: $!";
}
@@ -998,9 +1191,10 @@ sub cmd_sbuild {
}
sub cmd_quilt_fixup {
- badusage "incorrect arguments to dgit quilt-fixup";
+ badusage "incorrect arguments to dgit quilt-fixup" if @ARGV;
my $clogp = parsechangelog();
- commit_quilty_patch((getfield $clogp, 'Version'));
+ $version = getfield $clogp, 'Version';
+ build_maybe_quilt_fixup();
}
sub parseopts () {
@@ -1018,14 +1212,25 @@ sub parseopts () {
helponly();
} elsif (m/^--new$/) {
$new_package=1;
- } elsif (m/^--(\w+)=(.*)/s && ($om = $opts_opt_map{$1})) {
+ } elsif (m/^--(\w+)=(.*)/s &&
+ ($om = $opts_opt_map{$1}) &&
+ length $om->[0]) {
$om->[0] = $2;
- } elsif (m/^--(\w+):(.*)/s && ($om = $opts_opt_map{$1})) {
+ } elsif (m/^--(\w+):(.*)/s &&
+ ($om = $opts_opt_map{$1})) {
push @$om, $2;
} elsif (m/^--existing-package=(.*)/s) {
$existing_package = $1;
} elsif (m/^--distro=(.*)/s) {
$idistro = $1;
+ } elsif (m/^--clean=(dpkg-source|git|none)$/s) {
+ $cleanmode = $1;
+ } elsif (m/^--clean=(.*)$/s) {
+ badusage "unknown cleaning mode \`$1'";
+ } elsif (m/^--ignore-dirty$/s) {
+ $ignoredirty = 1;
+ } elsif (m/^--no-quilt-fixup$/s) {
+ $noquilt = 1;
} else {
badusage "unknown long option \`$_'";
}
@@ -1040,6 +1245,9 @@ sub parseopts () {
$debug++;
} elsif (s/^-N/-/) {
$new_package=1;
+ } elsif (m/^-[vm]/) {
+ push @changesopts, $_;
+ $_ = '';
} elsif (s/^-c(.*=.*)//s) {
push @git, '-c', $1;
} elsif (s/^-d(.*)//s) {
@@ -1048,6 +1256,12 @@ sub parseopts () {
$changesfile = $1;
} elsif (s/^-k(.*)//s) {
$keyid=$1;
+ } elsif (s/^-wn//s) {
+ $cleanmode = 'none';
+ } elsif (s/^-wg//s) {
+ $cleanmode = 'git';
+ } elsif (s/^-wd//s) {
+ $cleanmode = 'dpkg-source';
} else {
badusage "unknown short option \`$_'";
}
@@ -1056,6 +1270,12 @@ sub parseopts () {
}
}
+if ($ENV{$fakeeditorenv}) {
+ quilt_fixup_editor();
+}
+
+delete $ENV{'DGET_UNPACK'};
+
parseopts();
print STDERR "DRY RUN ONLY\n" if $dryrun;
if (!@ARGV) {
diff --git a/dgit.1 b/dgit.1
index 652ffbb..f97e458 100644
--- a/dgit.1
+++ b/dgit.1
@@ -12,7 +12,7 @@ dgit \- git integration with the Debian archive
[\fIsuite\fP]
.br
.B dgit
-[\fIdgit\-opts\fP] \fBbuild\fP|\fBsbuild\fP
+[\fIdgit\-opts\fP] \fBbuild\fP|\fBsbuild\fP|\fBbuild-source\fP
[\fIbuild\-opts\fp]
.br
.B dgit
@@ -33,9 +33,10 @@ as
which lives outside the Debian archive (currently, on Alioth).
The usual workflow is: 1. clone or fetch; 2. make and commit changes
-in git as desired; 3. run dgit build or dgit sbuild, or generate the
-source and binary packages for upload some other way; 4. do
-pre-upload tests of the proposed upload; 5. run dgit push.
+in git as desired; 3. run dgit build, dgit sbuild or dgit
+build-source, or generate the source and binary packages for upload
+some other way; 4. do pre-upload tests of the proposed upload; 5. run
+dgit push.
.TP
\fBdgit clone\fR \fIpackage\fP [\fIsuite\fP] [\fB./\fP\fIdir|\fB/\fP\fIdir\fR]
Consults the archive and dgit-repos to construct the git view of
@@ -81,21 +82,45 @@ into the current branch.
.TP
\fBdgit build\fR ...
Runs
-.B git-buildpackage
+.B dpkg-buildpackage
with some suitable options. Options and argumments after build
-will be passed on to git-buildpackage. It is not necessary to use
+will be passed on to dpkg-buildpackage. It is not necessary to use
dgit build when using dgit; it is OK to use any approach which ensures
that the generated source package corresponds to the relevant git
-commit. Tagging and signing should be left to dgit push.
+commit.
+
+Tagging, signing and actually uploading should be left to dgit push.
+.TP
+\fBdgit build-source\fR ...
+Builds the source package, and a changes file for a prospective
+source-only upload, using
+.BR dpkg-source .
+The output is left in
+.IR package \fB_\fR version \fB.dsc\fR
+and
+.IR package \fB_\fR version \fB_source.changes\fR.
+
+Tagging, signing and actually uploading should be left to dgit push.
.TP
\fBdgit sbuild\fR ...
-Constructs the source package, and uses sbuild to do a binary
-build, and uses mergechanges to merge the source and binary
-changes files. Options and argumments after sbuild will be passed on
-to sbuild. Changes files matching
+Constructs the source package, uses
+.B sbuild
+to do a binary build, and uses mergechanges to merge the source and
+binary changes files. Options and argumments after sbuild will be
+passed on to sbuild. Changes files matching
.IB package _ version _*.changes
in the parent directory will be removed; the output is left in
.IR package \fB_\fR version \fB_multi.changes\fR.
+
+Tagging, signing and actually uploading should be left to dgit push.
+.TP
+\fBdgit git-build\fR ...
+Runs
+.B git-buildpackage
+with some suitable options. Options and argumments after git-build
+will be passed on to git-buildpackage.
+
+Tagging, signing and actually uploading should be left to dgit push.
.TP
.B dgit push
Does an `upload', pushing the current HEAD to the archive (as a source
@@ -110,12 +135,6 @@ field, runs debsign to sign the upload (.dsc and .changes), pushes the
signed tag, and finally uses dput to upload the .changes to the
archive.
-For a format `3.0 (quilt)' source package, dgit push
-may also have to make a commit on your current branch to contain
-quilt metadata. It will do this automatically if necessary.
-You can explicitly request that dgit do just this
-dgit quilt-fixup.
-
dgit push always uses the package, suite and version specified in the
debian/changelog and the .dsc, which must agree.
@@ -123,15 +142,12 @@ If dgit push fails while uploading, it is fine to simply retry the
dput on the .changes file at your leisure.
.TP
.B dgit quilt-fixup
-Looks to see if there is quilt patch metadata left over by dpkg-source
--b, and if so makes a git commit of it. This is normally done
-automatically by dgit push. dgit quilt-fixup takes no additional
-arguments. Note that it will only process a patch generated by
-dpkg-source for the most recent version (according to the
-debia/changelog).
-
-It is not normally necessary to run dgit quilt-fixup explicitly;
-where necessary it is done as part of dgit push.
+Looks to see if the tree is one which dpkg-source cannot properly
+represent. If it isn't, dgit will fix it up for you (in quilt terms,
+by making a new debian/ patch containing your unquilty changes) and
+make a commit of the changes it has made.
+
+This is normally done automatically by dgit build and dgit push.
.SH WORKFLOW - SIMPLE
It is always possible with dgit to clone or fetch a package, make
changes in git (using git-commit) on the suite branch
@@ -256,15 +272,34 @@ in git and a fast-forwarding release branch; or you could do your work
directly in a merging way on the
.BI dgit/ suite
branches. If you do this you should probably use a `1.0' format
-source package. In the archive, the delta between upstream will be
-represented in the single Debian patch.
-
-Secondly, you can regard your quiltish patch stack in the archive as
-primary. You will have to use other tools besides dgit to import and
-export this patch stack. For `3.0 (quilt)' packages, dgit has to do
-more work to work around some braindamage in way dpkg-source handles
-changes made to this format. See also the BUGS section. We recommend
-against the use of `3.0 (quilt)'.
+source package if you can. In the archive, the delta between upstream
+will be represented in the single Debian patch.
+
+Secondly, you can use `3.0 (quilt)', and regard your quiltish patch
+stack in the archive as primary. You will have to use other tools
+besides dgit to import and export this patch stack. But see below:
+.SH FORMAT 3.0 (QUILT)
+For a format `3.0 (quilt)' source package, dgit may have to make a
+commit on your current branch to contain metadata used by quilt and
+dpkg-source.
+
+This is because (i) the `3.0 (quilt)' source format cannot represent
+certain trees, and (ii) packing up a tree in `3.0 (quilt)' and then
+unpacking it does not always yield the same tree. Instead,
+dpkg-source insists on the trees having extra quilty metadata and
+patch files in the debian/ and .pc/ directories, which dpkg-source
+sometimes modifies.
+
+dgit will automatically work around this braindamage for you when
+building and pushing. The only thing you need to know is that dgit
+build, sbuild, etc., may make a new commit on your HEAD. If you're
+not a quilt user this commit won't contain any changes to files you
+care about.
+
+You can explicitly request that dgit do just this fixup, by running
+dgit quilt-fixup.
+
+We recommend against the use of `3.0 (quilt)'.
.SH OPTIONS
.TP
.BR --dry-run | -n
@@ -288,10 +323,40 @@ Specifies that we should process source package
rather than looking in debian/control or debian/changelog.
Valid with dgit fetch and dgit pull, only.
.TP
+.BR --clean=git | -wg
+The source tree should be cleaned, before building a source package
+with one of the build options, using
+.BR "git clean -xdf" .
+This will delete all files which are not tracked by git.
+.TP
+.BR --clean=none | -wn
+Do not clean the tree before building a source package. If there are
+files which are not in git, a subsequent dgit push will fail.
+.TP
+.BR --clean=dpkg-source | -wd
+Use dpkg-buildpackage to do the build, so that the source package
+is cleaned by dpkg-source running the package's clean target.
+This is the default. It requires the package's build dependencies.
+.TP
.BR -N | --new
The package may be new in this suite. Without this, dgit will
refuse to push.
.TP
+.BR --ignore-dirty
+Do not complain if the working tree does not match your git HEAD.
+This can be useful with build, if you plan to commit later. (dgit
+push will still ensure that the .dsc you upload and the git tree
+you push are identical, so this option won't make broken pushes.)
+
+This option may not work properly on `3.0 (quilt)' packages, as in
+that case dgit needs to use and perhaps commit parts of your working
+tree.
+.TP
+.BR --no-quilt-fixup
+Do not fix up source format `3.0 (quilt)' metadata. If you use this
+option and the package did in fact need fixing up, dgit push will
+fail.
+.TP
.BI -D
Prints debugging information to stderr. Repeating the option produces
more output (currently, up to -DD is meaningfully different).
@@ -300,26 +365,41 @@ more output (currently, up to -DD is meaningfully different).
Specifies a git configuration option. dgit itself is also controlled
by git configuration options.
.TP
+.RI \fB-v\fR version |\fB-m\fR maintaineraddress
+Passed to dpkg-genchanges (eventually).
+.TP
+.RI \fB--ch:\fR option
+Specifies a single additional option to pass, eventually, to
+dpkg-genchanges.
+.TP
.RI \fB--dget=\fR program |\fB--dput=\fR program |...
Specifies alternative programs to use instead of
.BR dget ,
.BR dput ,
.BR debsign ,
-.BR dpkg-buildpackage
+.BR dpkg-source ,
+.BR dpkg-buildpackage ,
+.BR dpkg-genchanges ,
.BR sbuild ,
or
.BR mergechanges .
+This applies only when the program is invoked directly by dgit.
.TP
.RI \fB--dget:\fR option |\fB--dput:\fR option |...
Specifies a single additional option to pass to
.BR dget ,
.BR dput ,
.BR debsign ,
-.BR dpkg-buildpackage
+.BR dpkg-source ,
+.BR dpkg-buildpackage ,
+.BR dpkg-genchanges ,
.BR sbuild ,
or
.BR mergechanges .
Can be repeated as necessary.
+This applies only when the program is invoked directly by dgit.
+Usually, for passing options to dpkg-genchanges, use
+.BR --ch: \fIoption\fR.
.TP
.BR -d "\fIdistro\fR | " --distro= \fIdistro\fR
Specifies that the suite to be operated on is part of distro
@@ -465,14 +545,10 @@ the .orig.tar.gz could be transported via the git repo as git tags.
Doing this is made more complicated by the possibility of a `3.0
(quilt)' package with multiple .orig tarballs.
-`3.0 (quilt)' packages have an additional difficulty: if these are
-edited in the most normal way, and then fed to dpkg-buildpackage,
-dpkg-source will add extra quilt patch metadata to the source tree
-during the source package build. This extra metadata is then of
-course not included in the git history. So dgit push needs to commit
-it for you, to make sure that the git history and archive contents are
-identical. That this is necessary is a bug in the `3.0 (quilt)'
-format.
+dgit's build functions, and dgit push, should not make any changes to
+your current HEAD. Sadly this is necessary for packages in the `3.0
+(quilt)' source format. This is ultimately due to design problems in
+quilt and dpkg-source.
There should be an option which arranges for the `3.0 (quilt)'
autocommit to not appear on your HEAD, but instead only in the