summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2014-01-19 02:21:15 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2014-01-19 02:21:15 +0000
commit1433215598fbec3c84be732ca5379f6eb236e775 (patch)
treea03c8138938a0bc4b32546ee5e4da5fef48d4f5e
parent34a6ded2e36eb2a57f16597d8ec520849256f270 (diff)
failedcmd prints $us, not $_[0] - ie, dgit doesn't pretend, in the error message, to be its child.
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index af72941..32c0680 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,8 @@ dgit (0.21~~iwj) unstable; urgency=medium
Error message improvements:
* Use failedcmd to report errors when ssh psql fails. Closes:#734281.
+ * failedcmd prints $us, not $_[0] - ie, dgit doesn't pretend,
+ in the error message, to be its child.
* Do not report the (irrelevant) $? when madison parsing fails.
Packaging improvements:
diff --git a/dgit b/dgit
index 94b9ab1..0182b6f 100755
--- a/dgit
+++ b/dgit
@@ -332,7 +332,7 @@ sub printcmd {
}
sub failedcmd {
- { local ($!); printcmd \*STDERR, "$_[0]: failed command:", @_ or die $!; };
+ { local ($!); printcmd \*STDERR, "$us: failed command:", @_ or die $!; };
if ($!) {
fail "failed to fork/exec: $!";
} elsif (!($? & 0xff)) {