summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-22 16:48:05 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-22 16:48:08 +0100
commit3405b073420845d4e72202577537e013d91abd25 (patch)
tree44a02e611993600aa57424bab0b854eaeacb79d2
parent6be5332d24efc7a21c9b5c57ad30193badb16ff2 (diff)
dgit: git-debrebase interop: Add a missing debugcmd debugging print.
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2efcc9c..8f093d4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -26,6 +26,7 @@ dgit (5.2~) unstable; urgency=medium
Closes:#902006.
* Print a warning to stderr on `dgit fetch sid', if your vcs-git
remote url disagrees with what's in sid's .dsc.
+ * git-debrebase interop: Add a missing debugcmd debugging print.
test suite:
* Use nproc(1) rather than Sys::CPU. This is more portable and does not
diff --git a/dgit b/dgit
index 2365bfc..88db243 100755
--- a/dgit
+++ b/dgit
@@ -5569,6 +5569,7 @@ END
make-patches --quiet-would-amend));
# We tolerate soe snags that gdr wouldn't, by default.
if (act_local()) {
+ debugcmd "+",@cmd;
$!=0; $?=-1;
failedcmd @cmd if system @cmd and $?!=7;
} else {