summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-15 21:05:07 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-15 21:06:43 +0100
commit537c0a24ac667a7996e726fabfb645eb91d2b583 (patch)
tree115e8692c3aa1a2d549b4752db1b09fe97c0c317
parentd7615b2df06548d7454ab3ad1a309b475900ab4b (diff)
Test suite: tstunt-parsechangelog: Produce Timestamp field
Like official one does, nowadays. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xtests/tstunt/dpkg-parsechangelog3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a60f35a..fc7d222 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -119,6 +119,8 @@ dgit (1.5~~) unstable; urgency=medium
* Many new tests (especially for new functionality).
* Add missing debhelper (>=8) to test suite's global Depends.
* tstunt arrangements: Fix mishandling of PERLLIB, etc.
+ * tstunt-parsechangelog: Produce Timestamp field (like official one
+ does, now).
--
diff --git a/tests/tstunt/dpkg-parsechangelog b/tests/tstunt/dpkg-parsechangelog
index 436591f..ba6ef54 100755
--- a/tests/tstunt/dpkg-parsechangelog
+++ b/tests/tstunt/dpkg-parsechangelog
@@ -60,7 +60,8 @@ for (;;) {
Maintainer: $1
Date: $2
END
- last;
+ print "Timestamp: " or die $!;
+ exec qw(date +%s -d), $2; die $!;
} elsif (m/^ --\s*$/) {
last;
} elsif (!m/\S/) {