summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-30 21:59:43 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-30 22:46:35 +0000
commit641292893240af7b3fd429351cede2fb80a3e99b (patch)
treee86ee698483f9d8ca8048bf50f57d22c5fe76ecb
parent8c8c2c4e6d9b28d056f27cbf65354f2f0be88aa3 (diff)
Properly fetch all archive dgit view tags, as we intended.
This deals with the possible "bad object" problem from an in-archive copy. Any such in-archive copy should come with either an update to the suite branch on the dgit-repos server (if maybe it needed a pseudomerge for centrally maintained history), or be identical to the upload's version tag. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 19a1a9f..ed7fd90 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,6 +24,7 @@ dgit (2.9~) unstable; urgency=low
Closes:#842608.
* Cope when cloning suite which doesn't receive uploads,
like testing. Closes:#842621.
+ * Properly fetch all archive dgit view tags, as we intended.
--
diff --git a/dgit b/dgit
index b17ed21..f494bb4 100755
--- a/dgit
+++ b/dgit
@@ -2337,7 +2337,7 @@ END
# OK, now %want is exactly what we want for refs in @specs
my @fspecs = map {
- return () if !m/\*$/ && !exists $wantr{"refs/$_"};
+ !m/\*$/ && !exists $wantr{"refs/$_"} ? () :
"+refs/$_:".lrfetchrefs."/$_";
} @specs;