summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-19 21:39:04 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-19 21:39:04 +0100
commit7474eaa17f71f795b803993b0e1c38ff2afe6c1b (patch)
tree2ecd43758e5342c23d6e515ae2a616ce31a21cde
parentc717d18c105d867245779baf67389d60e8f3d772 (diff)
Test suite: Break out t-make-hook-link.
-rw-r--r--debian/changelog1
-rw-r--r--tests/lib18
2 files changed, 13 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 6f5ac4d..661c57b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -33,6 +33,7 @@ dgit (0.31~~) unstable; urgency=low
Cleanups:
* Remove an obsolete comment from the code.
* Improve an error message from dgit-repos-policy-debian.
+ * Test suite: Break out t-make-hook-link.
* Fix a manpage typo.
--
diff --git a/tests/lib b/tests/lib
index 1179fb0..e81a62a 100644
--- a/tests/lib
+++ b/tests/lib
@@ -567,14 +567,20 @@ t-policy-nonexist () {
ln -sf no-such-file-or-directory $drs_dispatch/policy-hook
}
-t-policy () {
- local policyhook=$1
- policyhook=${DGIT_INFRA_PFX}$policyhook
- case $policyhook in
+t-make-hook-link () {
+ local hook=$1 # in infra/
+ local linkpath=$2
+ hook=${DGIT_INFRA_PFX}$hook
+ case $hook in
*/*) ;;
- *) policyhook=`type -P $policyhook` ;;
+ *) hook=`type -P $hook` ;;
esac
- ln -sf "$policyhook" $drs_dispatch/policy-hook
+ ln -sf "$hook" $linkpath
+}
+
+t-policy () {
+ local policyhook=$1
+ t-make-hook-link $policyhook $drs_dispatch/policy-hook
}
t-debpolicy () {