summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-09 22:08:01 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-10-10 01:04:29 +0100
commitd76f34bfa71c438efec0aadf37482dea6360968a (patch)
tree14810307178aee234e6e615ee112000f2de665cb
parent3b0766cf7fd581dde3fb31b9264045fa201db77a (diff)
dgit: Get sense of failed clone failed cleanup error reporting check correct.
Closes:#796773. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e4f2630..9c52188 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -92,6 +92,8 @@ dgit (1.5~~) unstable; urgency=medium
etc. Closes:#827892.
* Allow local git config options to override user-global ones,
as is proper. Closes:#835858.
+ * Get sense of failed clone failed cleanup error reporting check
+ correct. Closes:#796773.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index b695905..7b16ff3 100755
--- a/dgit
+++ b/dgit
@@ -3381,7 +3381,7 @@ sub cmd_clone {
}
if (stat $dstdir) {
rmtree($dstdir) or die "remove $dstdir: $!\n";
- } elsif (!grep { $! == $_ }
+ } elsif (grep { $! == $_ }
(ENOENT, ENOTDIR, EACCES, EPERM, ELOOP)) {
} else {
print STDERR "check whether to remove $dstdir: $!\n";