summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-28 23:08:06 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-08-28 23:08:06 +0100
commit28789232f5edcc1c24bbb4bfe3b5e12119e9886e (patch)
treea64888a520ffb99bee5bc4ed3477cbbfc8f16479
parentbd9da469ec0702223270445ced410a54fb3d5158 (diff)
Do not always pointlessly fetch the .dsc twice. (That code was erroneously duplicated during editing, apparently.)
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 2 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index cb80d51..be670ab 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ dgit (0.13) unstable; urgency=low
* Reuse already-downloaded .orig files after checking their hashes.
Closes: #720526. (This introduces a dependency on the Digest::SHA.)
+ * Do not always pointlessly fetch the .dsc twice. (That code was
+ erroneously duplicated during editing, apparently.)
* Remove DGET_UNPACK from the environment in case the user has set it.
* Remove scary warning from Description.
diff --git a/dgit b/dgit
index 4550a86..9d1570c 100755
--- a/dgit
+++ b/dgit
@@ -443,8 +443,6 @@ sub get_archive_dsc () {
$dscurl = access_cfg('mirror').$subpath;
$dscdata = url_get($dscurl);
next unless defined $dscdata;
- $dscurl = access_cfg('mirror').$subpath;
- $dscdata = url_get($dscurl);
my $dscfh = new IO::File \$dscdata, '<' or die $!;
print DEBUG Dumper($dscdata) if $debug>1;
$dsc = parsecontrolfh($dscfh,$dscurl, allow_pgp=>1);