summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-12-14 21:39:10 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-12-19 16:58:57 +0000
commit761257ea4fc5cad5eac4a06e09d5ebabaab2296f (patch)
tree322b16efa7c3befdc6d68ad3def5d1384733fe0e
parent0b4f75ce504c8edc11283c0f813ef719b0ace6e6 (diff)
dgit: Give better advice if .dsc/.changes signing fails
If no changes are needed to the package, user may indeed just debsign and dput. Closes:#844131. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog3
-rwxr-xr-xdgit8
2 files changed, 9 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index cfd2e2b..d2127cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,9 @@ dgit (2.12~) unstable; urgency=medium
* Slightly better message when .dsc not found. Apropos of #844128.
* dgit-maint-native(7): Clarify that we mean native source format.
[Phil Hands] Closes:#847987.
+ * Give better advice if .dsc/.changes signing fails: if no changes
+ are needed to the package, user may indeed just debsign and dput.
+ Closes:#844131.
Test suite:
* Provide and use stunt lintian and debuild, to avoid lintian
diff --git a/dgit b/dgit
index ee82cd0..224d85b 100755
--- a/dgit
+++ b/dgit
@@ -3995,8 +3995,12 @@ END
runcmd_ordryrun @git, qw(update-ref -m), 'dgit push', lrref(), $dgithead;
supplementary_message(<<'END');
-Push failed, after updating the remote git repository.
-If you want to try again, you must use a new version number.
+Push failed, while obtaining signatures on the .changes and .dsc.
+If it was just that the signature failed, you may try again by using
+debsign by hand to sign the changes
+ $changesfile
+and then dput to complete the upload.
+If you need to change the package, you must use a new version number.
END
if ($we_are_responder) {
my $dryrunsuffix = act_local() ? "" : ".tmp";