summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 18:26:29 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-07-25 18:32:29 +0100
commit968202ab0b56d1d27f14703c208a88b9540024f7 (patch)
treeb942329807bff7e59d208f62691bf2e6d49b95c3
parent1f11185ae9aa5cca12ab61c56d49a4be9397d19d (diff)
Test suite: Check that test suite list in debian/tests/control is up to date
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/tests/control2
-rwxr-xr-xtests/tests/test-list-uptodate9
3 files changed, 11 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index ad842f3..0a5933b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,4 +38,4 @@ debian/tests/control: tests/list-tests debian/tests/control.in
$< gencontrol >$@.new && mv -f $@.new $@
debian/tests/control: tests/lib-core tests/lib-restricts
-debian/tests/control: $(wildcard tests/tests/*[^~#])
+debian/tests/control: tests/tests $(wildcard tests/tests/*[^~#])
diff --git a/debian/tests/control b/debian/tests/control
index bf4bc3f..9bd27a3 100644
--- a/debian/tests/control
+++ b/debian/tests/control
@@ -3,7 +3,7 @@ Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, rsync
Restrictions: x-dgit-intree-only x-dgit-git-only
-Tests: clone-gitnosuite clone-nogit debpolicy-dbretry debpolicy-newreject distropatches-reject drs-clone-nogit drs-push-masterupdate drs-push-rejects dsd-clone-nogit dsd-divert fetch-localgitonly fetch-somegit-notlast mirror mirror-debnewgit mirror-private push-buildproductsdir push-newpackage push-nextdgit quilt rpush tag-updates trustingpolicy-replay
+Tests: clone-gitnosuite clone-nogit debpolicy-dbretry debpolicy-newreject distropatches-reject drs-clone-nogit drs-push-masterupdate drs-push-rejects dsd-clone-nogit dsd-divert fetch-localgitonly fetch-somegit-notlast mirror mirror-debnewgit mirror-private push-buildproductsdir push-newpackage push-nextdgit quilt rpush tag-updates test-list-uptodate trustingpolicy-replay
Tests-Directory: tests/tests
Depends: dgit, dgit-infrastructure, devscripts, rsync
diff --git a/tests/tests/test-list-uptodate b/tests/tests/test-list-uptodate
new file mode 100755
index 0000000..a2b4c5b
--- /dev/null
+++ b/tests/tests/test-list-uptodate
@@ -0,0 +1,9 @@
+#!/bin/bash
+set -e
+. tests/lib
+
+: "just verifies internal consistency of test suite"
+
+cd $root
+$troot/list-tests gencontrol >$tmp/control-expected
+diff debian/tests/control $tmp/control-expected