summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-26 18:30:24 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2018-06-26 19:20:54 +0100
commit3413485f2c7fbb36dfc4c6bf42176cd228511985 (patch)
treedf1b8e8de0be11b441cbda87d21066fe387090aa
parent11c8c965c3419fddf2444a7497b45b65f05d3db5 (diff)
ref updates: Honour GIT_REFLOG_ACTION everywhere.
Specifically, every time we call git_update_ref_cmd. Closes:#901935. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--Debian/Dgit.pm2
-rw-r--r--debian/changelog3
2 files changed, 4 insertions, 1 deletions
diff --git a/Debian/Dgit.pm b/Debian/Dgit.pm
index 2bac485..0a99faa 100644
--- a/Debian/Dgit.pm
+++ b/Debian/Dgit.pm
@@ -496,6 +496,8 @@ sub git_update_ref_cmd {
# returns qw(git update-ref), qw(-m), @_
# except that message may be modified to honour GIT_REFLOG_ACTION
my $msg = shift @_;
+ my $rla = $ENV{GIT_REFLOG_ACTION};
+ $msg = "$rla: $msg" if length $rla;
return qw(git update-ref -m), $msg, @_;
}
diff --git a/debian/changelog b/debian/changelog
index 763c427..70d600f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
dgit (5.3~) unstable; urgency=medium
- *
+ Bugfixes:
+ * Honour GIT_REFLOG_ACTION everywhere. Closes:#901935.
--