summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-20 14:00:42 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2015-08-20 14:00:42 +0100
commit38d77cdb611b6a8d0a719ce50e9fc57562c0d085 (patch)
treed604c489a87eef23ed6c9fd5e6fb8db3a000c5f1
parentb3e6081e1bdfa93adc1dc962de085754428fa7e4 (diff)
Copy debian/source/options into fake dsc
-rwxr-xr-xdgit4
1 files changed, 2 insertions, 2 deletions
diff --git a/dgit b/dgit
index 2434f6a..c1c8b64 100755
--- a/dgit
+++ b/dgit
@@ -2747,7 +2747,7 @@ sub build_maybe_quilt_fixup () {
# can work. We do this as follows:
# 1. Collect all relevant .orig from parent directory
# 2. Generate a debian.tar.gz out of
- # debian/{patches,rules,source/format}
+ # debian/{patches,rules,source/format,source/options}
# 3. Generate a fake .dsc containing just these fields:
# Format Source Version Files
# 4. Extract the fake .dsc
@@ -2808,7 +2808,7 @@ END
}
my @files=qw(debian/source/format debian/rules);
- foreach my $maybe (qw(debian/patches)) {
+ foreach my $maybe (qw(debian/patches debian/source/options)) {
next unless stat_exists "../../../$maybe";
push @files, $maybe;
}