summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-09-26 01:14:00 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-09-26 01:14:00 +0100
commit68dadfa3503db1f12b4402bbf043d51441a9a412 (patch)
tree88259eed75e7b3d8a7bf7914c6cc0141595b0252
parent230f01deca3c9802b1fbe439cbec393d74527f04 (diff)
wip changes for remote push - beginning with remote protocol
-rw-r--r--debian/changelog2
-rwxr-xr-xdgit2
2 files changed, 3 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 104b6bb..bb7ff04 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
dgit (0.16~experimental2) experimental; urgency=low
- *
+ * WIP remote functionality. Untested, do not use.
--
diff --git a/dgit b/dgit
index 5cdf21e..2fb3e0e 100755
--- a/dgit
+++ b/dgit
@@ -906,6 +906,8 @@ sub push_parse_changelog ($) {
my $clogp = Dpkg::Control::Hash->new();
$clogp->load($clogpfn);
+ responder_send_file('parsed-changelog', $clogpfn);
+
$package = getfield $clogp, 'Source';
my $cversion = getfield $clogp, 'Version';
my $tag = debiantag($cversion);