summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-26 01:05:32 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2016-09-26 01:36:40 +0100
commit691b12e13974d68966a397186cc5e310e5582f0f (patch)
tree4d97ae93b6e893147f44454bd023231595aa06a1
parent5c99625328b84337f2267c3ebdc54b4a93409198 (diff)
dgit: getfield, parsechangelog: Fix two bugs in error reporting
Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 625fedd..c493edd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -51,6 +51,7 @@ dgit (1.5~~) unstable; urgency=medium
* When synthesing a commit from a .dsc from the archive, stop
internal git reset from printing a confusing message about HEAD.
* Turn off git gc in the private working areas.
+ * Fix a couple of bugs in error reporting.
Test suite:
* When sbuild fails, do not crash due to sed not finding the log
diff --git a/dgit b/dgit
index 373854e..54337f7 100755
--- a/dgit
+++ b/dgit
@@ -872,11 +872,11 @@ sub getfield ($$) {
my ($dctrl,$field) = @_;
my $v = $dctrl->{$field};
return $v if defined $v;
- fail "missing field $field in ".$v->get_option('name');
+ fail "missing field $field in ".$dctrl->get_option('name');
}
sub parsechangelog {
- my $c = Dpkg::Control::Hash->new();
+ my $c = Dpkg::Control::Hash->new(name => 'parsed changelog');
my $p = new IO::Handle;
my @cmd = (qw(dpkg-parsechangelog), @_);
open $p, '-|', @cmd or die $!;