summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-16 16:00:21 +0000
committerIan Jackson <ijackson@chiark.greenend.org.uk>2017-01-16 16:01:16 +0000
commit6a5bd9349a52be72e3344c02e5337a3bd205939c (patch)
tree931280b243885a9ac9c2fcc54edfc0bf373591f8
parentd0d42986f5f79e5c1e4f421c92b023c688ba9957 (diff)
test suite; drs-push-rejects: Set origin's url
Use an ad-hoc expression which produces the right ext:: rune, as dgit would. Closes:#851580. Signed-off-by: Ian Jackson <ijackson@chiark.greenend.org.uk>
-rw-r--r--debian/changelog5
-rwxr-xr-xtests/tests/drs-push-rejects3
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 5febef8..b3ab01e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
dgit (3.4~) unstable; urgency=medium
- *
+ Test suite:
+ * drs-push-rejects: Set origin's url to an ad-hoc expression
+ which produces the right ext:: rune, as dgit would.
+ Closes:#851580.
--
diff --git a/tests/tests/drs-push-rejects b/tests/tests/drs-push-rejects
index 4b7de34..afaed4c 100755
--- a/tests/tests/drs-push-rejects
+++ b/tests/tests/drs-push-rejects
@@ -10,6 +10,9 @@ t-worktree drs
cd $p
+git remote set-url origin \
+ "ext::$troot/drs-git-ext %S /pari-extra.git"
+
mustfail () {
local mpat="$1"; shift
t-expect-push-fail "$mpat" \