summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-22 15:11:05 +0100
committerIan Jackson <ijackson@chiark.greenend.org.uk>2013-10-22 15:11:05 +0100
commit8922b4bef17886da65d1ac33eede20ade9fa4197 (patch)
treef3bc470c49ad10f51428a13f014cf276cc50c4f9
parent41e0ec2b26cba9b3d4016b195ec8795ca1bd40f4 (diff)
fix protocol_receive_file not to use STDIN
-rw-r--r--debian/changelog1
-rwxr-xr-xdgit4
2 files changed, 3 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 8c37c8f..1dfefb3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ dgit (0.17) unstable; urgency=low
* Fix dgit --damp-run sbuild to actually work.
* Improvements to implementation of --dry-run and --damp-run.
+ * More fixes to remote implementation.
--
diff --git a/dgit b/dgit
index b1ed904..549b251 100755
--- a/dgit
+++ b/dgit
@@ -223,9 +223,9 @@ sub protocol_receive_file ($$) {
my ($y,$l) = protocol_expect {
m/^data-block (.*})$|data-end$/;
length $1 ? (1,$1) : (0);
- } \*STDIN;
+ } $fh;
last unless $y;
- my $d = protocol_read_bytes \*STDIN, $1;
+ my $d = protocol_read_bytes $fh, $1;
print PF $d or die $!;
}
printdebug "received into $ourfn\n";